aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt5-qtbase
Commit message (Collapse)AuthorAgeFilesLines
* community/qt5-qtbase: upgrade to 5.12.0André Klitzing2018-12-283-40/+4
|
* community/qt5-qtbase: rebuild against openssl 1.1Natanael Copa2018-11-071-2/+2
|
* community/qt5-qtbase: Enable the X11 Accessibility BridgeLuca Weiss2018-10-021-1/+2
|
* community/qt5-qtbase: rebuild against icu-62.1Natanael Copa2018-10-011-1/+1
|
* community/qt5-qtbase: upgrade to 5.10.1Natanael Copa2018-05-012-107/+21
|
* community/qt5-qtbase: rebuild against libressl-2.7Natanael Copa2018-04-061-1/+1
|
* community/qt5-qtbase: rebuild against mariadb-connector-cNatanael Copa2018-03-261-2/+2
|
* community: rebuild against icu-60.2William Pitcock2018-02-271-1/+1
|
* community/qt5-qtbase: Allow more ssl API use (libressl compat patch)Jussi Kukkonen2018-02-272-10/+1
| | | | | Current libressl actually supports SSL_CTRL_SET_CURVES: don't prevent using it with libressl.
* [various]: unify names of licenses according to SPDXJakub Jirutka2017-12-301-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This commit updates $license variable in all APKBUILDs to comply with short names specified by SPDX version 3.0 [1] where possible. It was done using find-and-replace method on substrings inside $license variables. Only license names were updated, not "expressions" specifying relation between the licenses (e.g. "X and Y", "X or Y", "X and (Y or Z)") or exceptions (e.g. "X with exceptions"). Many licenses have a version or multiple variants, e.g. MPL-2.0, BSD-2-Clause, BSD-3-Clause. However, $license in many aports do not contain license version or variant. Since there's no way how to infer this information just from abuild, it were left without the variant suffix or version, i.e. non SPDX compliant. GNU licenses (AGPL, GFDL, GPL, LGPL) are especially complicated. They exist in two variants: -only (formerly e.g. GPL-2.0) and -or-later (formerly e.g. GPL-2.0+). We did not systematically noted distinguish between these variants, so GPL-2.0, GPL2, GPLv2 etc. may mean GPL-2.0-only or GPL-2.0-or-later. Thus GNU licenses without "+" (e.g. GPL2+) were left without the variant suffix, i.e. non SPDX compliant. Note: This commit just fixes format of the license names, no verification has been done if the specified license information is actually correct! [1]: https://spdx.org/licenses/
* community/qt5-qtbase: upgrade to 5.9.3, improved APKBUILDFrancesco Colista2017-12-021-30/+21
|
* community/qt5-qtbase: rebuild against libressl-2.6Natanael Copa2017-11-091-1/+1
|
* community/qt5-qtbase: rebuild against icu-59.1Natanael Copa2017-07-181-1/+1
|
* community/qt5-qtbase: upgrade to 5.9.1Natanael Copa2017-07-053-183/+5
|
* community/qt5-qtbase: disable precompiled headersNatanael Copa2017-07-031-1/+2
|
* community/qt5-qtbase: fix QTBUG-56140Leonardo Arena2017-06-072-2/+84
|
* community/qt5-qtbase: big endian bug on s390xTuan M. Hoang2017-04-202-1/+97
| | | | | Ref https://code.qt.io/cgit/qt/qtbase.git/commit/?id=6f64bfa654fb7e20bb75ec3b0544b81482babb44
* community/qt5-qtbase: rebuild against libressl 2.5Natanael Copa2017-04-181-1/+1
|
* community/qt5-qt*: move from mainNatanael Copa2017-04-144-0/+355