aboutsummaryrefslogtreecommitdiffstats
path: root/community/shotwell
Commit message (Collapse)AuthorAgeFilesLines
* community: mask librsvg dependencies on mips and mips64Ariadne Conill3 days1-1/+1
|
* community/*: make CMake and meson respect our C{,PP,XX}FLAGSRasmus Thomsen2020-02-211-2/+2
| | | | See: https://lists.alpinelinux.org/~alpine/devel/%3C2896c13070c508a49cbaa72c8fb7f34ea947358b.camel%40cogitri.dev%3E
* community/shotwell: upgrade to 0.30.8Rasmus Thomsen2020-01-101-3/+3
|
* tree-wide: use --buildtype=debugoptimized for meson packagesRasmus Thomsen2020-01-071-2/+2
| | | | | | | As of now we're using the buildttype 'release', which produces optimized builds but without any usable debugging info, which makes debugging crashes impossible, even if a -dbg subpackage exists. As such we should build in the buildmode 'debugoptimized' to offer proper debug symbols.
* community/shotwell: disable on s390x due to librsvgRasmus Thomsen2019-10-241-1/+1
| | | Closes !509
* community/shotwell: upgrade to 0.30.7Rasmus Thomsen2019-09-064-42/+23
| | | | | | | | * Switch to meson * Fix license * Remove ancient GConf stuff * Enable on all arches * Adopt maintainership
* community/shotwell: rebuild against exiv2-0.27.2Leonardo Arena2019-08-131-1/+1
|
* community/shotwell: Provided support for aarch64 Architecture specific ↵ossdev2019-06-181-1/+1
| | | | | | condition has been added for aarch64 Signed-off-by: ossdev <ossdev@puresoftware.com>
* community/shotwell: modernizeLeo2019-05-291-5/+1
| | | Closes GH-8227
* aports: add support for armv7 [skip ci]Oliver Smith2018-09-241-1/+1
| | | | | | | | | This makes it possible to provide armv7 as additional architecture in Alpine, next to armhf. See the discussion in this ML thread: <https://lists.alpinelinux.org/alpine-devel/6271.html> It's done by adding armv7 next to armhf in the arch line and also !armv7 where the arch line said !armhf. The following script was used:
* community/shotwell: upgrade to 0.28.2prspkt2018-07-131-3/+3
|
* community/shotwell: upgrade to 0.27.4Roberto Oliveira2018-03-191-2/+2
|
* community/[various]: enable build on s390xTuan M. Hoang2018-02-131-1/+1
| | | | | enable build webkit2gtk, shotwell, midori fix local variable _archopt
* community/shotwell: upgrade to 0.27.3Roberto Oliveira2018-01-201-2/+2
|
* [various]: unify names of licenses according to SPDXJakub Jirutka2017-12-301-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This commit updates $license variable in all APKBUILDs to comply with short names specified by SPDX version 3.0 [1] where possible. It was done using find-and-replace method on substrings inside $license variables. Only license names were updated, not "expressions" specifying relation between the licenses (e.g. "X and Y", "X or Y", "X and (Y or Z)") or exceptions (e.g. "X with exceptions"). Many licenses have a version or multiple variants, e.g. MPL-2.0, BSD-2-Clause, BSD-3-Clause. However, $license in many aports do not contain license version or variant. Since there's no way how to infer this information just from abuild, it were left without the variant suffix or version, i.e. non SPDX compliant. GNU licenses (AGPL, GFDL, GPL, LGPL) are especially complicated. They exist in two variants: -only (formerly e.g. GPL-2.0) and -or-later (formerly e.g. GPL-2.0+). We did not systematically noted distinguish between these variants, so GPL-2.0, GPL2, GPLv2 etc. may mean GPL-2.0-only or GPL-2.0-or-later. Thus GNU licenses without "+" (e.g. GPL2+) were left without the variant suffix, i.e. non SPDX compliant. Note: This commit just fixes format of the license names, no verification has been done if the specified license information is actually correct! [1]: https://spdx.org/licenses/
* community/shotwell: upgrade to 0.27.2Natanael Copa2017-12-251-2/+2
|
* community/shotwell: upgrade to 0.27.1Natanael Copa2017-10-311-2/+2
|
* community/shotwell: enable build on ppc64leRoberto Oliveira2017-09-281-1/+1
|
* community/shotwell: upgrade to 0.27.0, modernize APKBUILD, added check()Francesco Colista2017-09-151-12/+13
|
* community/shotwell: rename gst*1Natanael Copa2017-07-061-2/+2
|
* community/shotwell: upgrade to 0.26.2Natanael Copa2017-06-141-2/+2
|
* community/shotwell: upgrade to 0.26.1Natanael Copa2017-04-121-3/+3
|
* community/shotwell: upgrade to 0.25.5Natanael Copa2017-02-161-4/+2
|
* community/shotwell: upgrade to 0.25.4Natanael Copa2017-02-011-4/+4
|
* community/shotwell: upgrade to 0.25.0Carlo Landmeter2016-11-041-23/+13
|
* community/shotwell: disable compile gschemasNatanael Copa2016-05-041-1/+2
|
* community/shotwell: rebuild with libgudevNatanael Copa2016-04-291-2/+2
|
* community/shotwell: upgrade to 0.23.0Natanael Copa2016-04-282-50369/+4
|
* community/shotwell: upgrade to 0.22.1 + latest gitNatanael Copa2016-04-202-24525/+19026
|
* community/shotwell: disable on armhfSören Tempel2016-02-061-1/+1
| | | | | The dependency webkit2gtk is currently not available for armhf thus shotwell refuses to build on armhf.
* community/shotwell: use webkit2gtkNatanael Copa2016-02-052-7/+55872
| | | | | the older webkit is no longer maintained so grab patches from git to use webkit2gtk.
* community/shotwell: move from mainNatanael Copa2015-10-294-0/+70