aboutsummaryrefslogtreecommitdiffstats
path: root/community/uncrustify/APKBUILD
Commit message (Collapse)AuthorAgeFilesLines
* community/uncrustify: upgrade to 0.71.0André Klitzing13 days1-3/+3
|
* community/uncrustify: modernizeLeo2020-03-021-13/+9
|
* community/uncrustify: upgrade to 0.70.1André Klitzing2019-11-271-2/+2
|
* community/uncrustify: upgrade to 0.70.0Leo2019-11-221-5/+5
|
* community/uncrustify: use python3Leo2019-10-231-6/+4
|
* community/uncrustify: upgrade to 0.69.0André Klitzing2019-05-141-2/+2
|
* community/uncrustify: upgrade to 0.68.1André Klitzing2018-11-241-2/+2
|
* community/uncrustify: upgrade to 0.68André Klitzing2018-11-221-3/+3
|
* community: (Bulk change) Update source urls to https using HTTPS EverywhereJ0WI2018-10-061-1/+1
|
* community/uncrustify: disable verbatim_strings test on s390xTuan M. Hoang2018-05-251-1/+2
| | | | | | verbatim_strings test checks the difference between tab character and '\t' in C#. The resulted test string is correct, cross-checked with x86*, but still show warning/error on s390x. Disable the test for now.
* community/uncrustify: upgrade to 0.67André Klitzing2018-05-191-2/+2
|
* [various]: unify names of licenses according to SPDXJakub Jirutka2017-12-301-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This commit updates $license variable in all APKBUILDs to comply with short names specified by SPDX version 3.0 [1] where possible. It was done using find-and-replace method on substrings inside $license variables. Only license names were updated, not "expressions" specifying relation between the licenses (e.g. "X and Y", "X or Y", "X and (Y or Z)") or exceptions (e.g. "X with exceptions"). Many licenses have a version or multiple variants, e.g. MPL-2.0, BSD-2-Clause, BSD-3-Clause. However, $license in many aports do not contain license version or variant. Since there's no way how to infer this information just from abuild, it were left without the variant suffix or version, i.e. non SPDX compliant. GNU licenses (AGPL, GFDL, GPL, LGPL) are especially complicated. They exist in two variants: -only (formerly e.g. GPL-2.0) and -or-later (formerly e.g. GPL-2.0+). We did not systematically noted distinguish between these variants, so GPL-2.0, GPL2, GPLv2 etc. may mean GPL-2.0-only or GPL-2.0-or-later. Thus GNU licenses without "+" (e.g. GPL2+) were left without the variant suffix, i.e. non SPDX compliant. Note: This commit just fixes format of the license names, no verification has been done if the specified license information is actually correct! [1]: https://spdx.org/licenses/
* community/uncrustify: upgrade to 0.66.1André Klitzing2017-11-231-6/+4
|
* community/uncrustify: disable failing testNatanael Copa2017-11-151-3/+5
|
* community/uncrustify: upgrade to 0.66 and add checkAndré Klitzing2017-11-151-3/+7
|
* community/uncrustify: upgrade to 0.65André Klitzing2017-05-241-5/+3
|
* testing/uncrustify: move to communityAndré Klitzing2017-03-241-0/+35