aboutsummaryrefslogtreecommitdiffstats
path: root/community
Commit message (Collapse)AuthorAgeFilesLines
* community/knot: upgrade to 2.7.8Jakub Jirutka2020-01-011-3/+3
|
* community/drupal7: security upgrade to 7.69Andy Postnikov2019-12-261-3/+3
|
* community/zabbix: upgrade to 4.0.16Leonardo Arena2019-12-241-2/+2
|
* community/php7: security upgrade to 7.2.26Andy Postnikov2019-12-191-2/+6
| | | | | | - CVE-2019-11045 - CVE-2019-11047 - CVE-2019-11050
* community/nextcloud: upgrade to 15.0.14Leonardo Arena2019-12-191-2/+2
|
* community/zabbix: upgrade to 4.0.15Leonardo Arena2019-12-021-2/+2
|
* community/py-psutil: fix CVE-2019-18874Leo2019-11-282-3/+586
|
* community/nextcloud: upgrade to 15.0.3Leonardo Arena2019-11-111-2/+2
|
* community/imagemagick6: upgrade to 6.9.10.69Jakub Jirutka2019-10-291-2/+2
|
* community/php7: security upgrade to 7.2.24 - CVE-2019-11043Andy Postnikov2019-10-261-2/+4
| | | Closes GH-11976
* community/exim: upgrade to 4.92.3J0WI2019-10-241-2/+4
|
* community/imagemagick6: security upgrade to 6.9.10.68J0WI2019-10-171-2/+2
|
* community/imagemagick6: upgrade to 6.9.10.62J0WI2019-10-171-2/+2
|
* community/openjdk8: security upgrade to 8.222.10J0WI2019-10-011-12/+21
| | | | | | | | | | | CVE-2019-2745 CVE-2019-2762 CVE-2019-2766 CVE-2019-2769 CVE-2019-2786 CVE-2019-2816 CVE-2019-2842 CVE-2019-7317
* community/milter-greylist: typo in init scriptLeonardo Arena2019-09-302-2/+2
|
* community/nextcloud: upgrade to 15.0.12Leonardo Arena2019-09-261-2/+2
|
* community/milter-greylist: start daemon after networkLeonardo Arena2019-09-242-5/+6
|
* community/exim: security upgrade to 4.92.2J0WI2019-09-091-3/+5
| | | | CVE-2019-15846
* community/exim: upgrade to 4.92.1Leo2019-09-091-2/+4
| | | | ref #10694
* community/firefox-esr: security update to 60.9.0J0WI2019-09-061-2/+10
|
* community/php7: security upgrade to 7.2.22Andy Postnikov2019-08-291-2/+2
|
* community/zabbix: upgrade to 4.0.12Leonardo Arena2019-08-291-2/+2
|
* community/ffmpeg: security upgrade to 4.0.4J0WI2019-08-181-3/+8
| | | | | | | | CVE-2018-15822 CVE-2019-9718 CVE-2019-9721 CVE-2019-11339 Closes GH-10195
* community/nextcloud: upgrade to 15.0.11Leonardo Arena2019-08-161-2/+2
|
* community/alpine-make-rootfs: upgrade to 0.3.1Jakub Jirutka2019-08-161-2/+2
|
* community/znc: add patch to fix CVE-2019-12816Rasmus Thomsen2019-08-152-2/+109
| | | | ref #10732
* community/ruby-nokogiri: rebuild against libxml 2.9.9Jakub Jirutka2019-08-141-1/+1
|
* community/imagemagick6: upgrade to 6.9.10.60Jakub Jirutka2019-08-141-2/+2
|
* community/openjdk8: add missing nss dependency to -jre-baseJakub Jirutka2019-08-121-2/+2
| | | | See #10126 and a0a5ffcea690a74b6f8c240d811be43542af60a6
* community/openjdk7: add missing patchLeo2019-08-031-0/+24
|
* community/pdns: add missing schema filetcely2019-08-032-0/+33
|
* community/pdns: security upgrade to 4.1.11Leo2019-08-032-4/+17
|
* community/php7: security upgrade to 7.2.21 - CVE-2019-11041 - CVE-2019-11041Andy Postnikov2019-08-021-2/+5
|
* community/zabbix: upgrade to 4.0.11Leonardo Arena2019-08-011-2/+2
|
* community/openjdk7: security upgrade to 7.221.2.6.18J0WI2019-07-311-13/+17
|
* community/imagemagick6: security upgrade to 6.9.10.55J0WI2019-07-241-2/+28
|
* community/imagemagick6: security upgrade to 6.9.10-53J0WI2019-07-241-4/+4
|
* community/imagemagick6: upgrade to 6.9.10.47J0WI2019-07-241-7/+2
|
* community/firefox-esr: security upgrade to 60.8.0J0WI2019-07-241-2/+13
|
* community/firefox-esr: security upgrade to 60.7.2 (CVE-2019-11708)J0WI2019-07-241-2/+4
| | | | fixes #10601
* community/firefox-esr: security upgrade to 60.7.1 (CVE-2019-11707)Natanael Copa2019-07-241-2/+4
|
* community/firefox-esr: upgrade to 60.7.0Sören Tempel2019-07-241-2/+19
| | | | See https://www.mozilla.org/en-US/security/advisories/mfsa2019-14/
* community/firefox-esr: upgrade to 60.6.2Sören Tempel2019-07-241-2/+2
| | | | | | This re-enables web extensions. See: https://www.mozilla.org/en-US/firefox/60.6.2/releasenotes/
* community/gvfs: backport fixes for a few CVEsLeo2019-07-225-3/+354
| | | | | | | - CVE-2019-12795 - CVE-2019-12449 - CVE-2019-12447 - CVE-2019-12448
* community/openexr: fix CVE-2018-18444Leo2019-07-212-3/+33
| | | | Fixes https://gitlab.alpinelinux.org/alpine/aports/issues/10395
* community/libraw: add missing CVEs to secfixes commentLeo2019-07-211-0/+3
|
* community/docker: upgrade to 18.09.8Jake Buchholz2019-07-201-10/+13
| | | | | | | https://github.com/docker/docker-ce/releases/tag/v18.09.8 * Fix CVE-2019-13509 in DebugRequestMiddleware: unconditionally scrub data field. Also, compile docker engine with seccomp.
* community/webkit2gtk: enable on x86Natanael Copa2019-07-171-1/+4
| | | | | Enable x86 and work around out of meomory error by disable _FORTIFY_SOURCE.
* community/webkit2gtk: upgrade to 2.24.3 and enable on armNatanael Copa2019-07-172-46/+16
| | | | | | | - build with MinSizeRel and -g1 to reduce memory usage during compile - simplify cmake opts. default seems to do the right thing nowdays - use nijna - remove patch that apparetnly is not needed anymore
* community/webkit2gtk: upgrade to 2.24.2Rasmus Thomsen2019-07-175-41/+70
| | | | | | | | | | | | | | | | | | | | | | | | | | | | * Disable armv7/armhf, due to using a 32-bit kernel these arches can't allocate enough memory during compilation for the massive compilation units webkit2gtk does. We'll have to wait for 2.26.x to allow compilation without unified sources to upgrade these arches. * Disable GTK_DOC, which fails to build * Disable system malloc on some arches. There were typos in the options anyway, so they haven't done anything anyway. System malloc is discouraged by upstream since bmalloc not only performs better it also has some security related advantages. fixes the following CVEs: * CVE-2019-6251 * CVE-2019-8506 * CVE-2019-8524 * CVE-2019-8535 * CVE-2019-8536 * CVE-2019-8544 * CVE-2019-8551 * CVE-2019-8558 * CVE-2019-8559 * CVE-2019-8563 * CVE-2019-11070 Co-authored-by: TBK <tbk@jjtc.eu>