aboutsummaryrefslogtreecommitdiffstats
path: root/testing/luakit/APKBUILD
Commit message (Collapse)AuthorAgeFilesLines
* testing/luakit: disable on ppc64le due to testsuite hangsNatanael Copa2019-03-051-1/+1
|
* testing/luakit: disable on x86 due to build failureNatanael Copa2019-03-051-1/+1
| | | | | | | | | | | | | | | | | | Build on x86 fails with: Reading 'doc/luadoc/pages/03-quick-start-guide.md'...luajit: build-utils/docgen/gen.lua:27: invalid ref '"new-window-decision"' stack traceback: [C]: in function 'assert' build-utils/docgen/gen.lua:27: in function <build-utils/docgen/gen.lua:23> [C]: in function 'gsub' build-utils/docgen/gen.lua:23: in function 'format_text' build-utils/docgen/gen.lua:379: in function 'gen' build-utils/docgen/gen.lua:513: in function 'generate_documentation' ./build-utils/docgen/makedoc.lua:84: in main chunk [C]: at 0x565748bb
* testing/luakit: enable testsAlex Raschi2019-03-051-8/+17
| | | | * move a dir in -doc subpackage too
* testing/luakit: upgrade to 2.1Natanael Copa2019-01-211-3/+3
| | | | fixes #9872
* testing/luakit: disable on s390x due to luajitNatanael Copa2018-02-101-1/+1
|
* [various]: unify names of licenses according to SPDXJakub Jirutka2017-12-301-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This commit updates $license variable in all APKBUILDs to comply with short names specified by SPDX version 3.0 [1] where possible. It was done using find-and-replace method on substrings inside $license variables. Only license names were updated, not "expressions" specifying relation between the licenses (e.g. "X and Y", "X or Y", "X and (Y or Z)") or exceptions (e.g. "X with exceptions"). Many licenses have a version or multiple variants, e.g. MPL-2.0, BSD-2-Clause, BSD-3-Clause. However, $license in many aports do not contain license version or variant. Since there's no way how to infer this information just from abuild, it were left without the variant suffix or version, i.e. non SPDX compliant. GNU licenses (AGPL, GFDL, GPL, LGPL) are especially complicated. They exist in two variants: -only (formerly e.g. GPL-2.0) and -or-later (formerly e.g. GPL-2.0+). We did not systematically noted distinguish between these variants, so GPL-2.0, GPL2, GPLv2 etc. may mean GPL-2.0-only or GPL-2.0-or-later. Thus GNU licenses without "+" (e.g. GPL2+) were left without the variant suffix, i.e. non SPDX compliant. Note: This commit just fixes format of the license names, no verification has been done if the specified license information is actually correct! [1]: https://spdx.org/licenses/
* testing/luakit: move luajit-dev to makedependsSören Tempel2017-09-161-3/+3
|
* testing/luakit: don't build with -ggdbSören Tempel2017-09-161-3/+5
|
* testing/luakit: explicitly set DEVELOPMENT_PATHSSören Tempel2017-09-161-1/+1
|
* testing/luakit: new aportSören Tempel2017-09-151-0/+28