aboutsummaryrefslogtreecommitdiffstats
path: root/community/apk-gtk/APKBUILD
blob: 5f0805e3e28d1e49d282e6dd94c0a01d22ece19c (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=apk-gtk
pkgver=0.1
pkgrel=0
pkgdesc="gtk+ frontend to apk"
url="http://github.com/kaniini/apk-gtk"
arch="all"
license="MIT"
depends=""
makedepends="gtk+2.0-dev gtk+3.0-dev vte-dev vte3-dev"
install=""
subpackages="$pkgname-gtk3 $pkgname-policy::noarch"
source="apk-gtk-$pkgver.tar.gz::https://github.com/kaniini/apk-gtk/archive/v$pkgver.tar.gz"
builddir="$srcdir/apk-gtk-$pkgver"

build() {
	cd "$builddir"

	make GTK_VERSION=3 || return 1
	cp apk-gtk apk-gtk.3

	make clean || return 1
	make GTK_VERSION=2 || return 1
}

package() {
	depends="$pkgname-policy"

	cd "$builddir"
	make GTK_VERSION=2 DESTDIR="$pkgdir" install || return 1
}

policy() {
	depends=""
	pkgdesc="gtk+ frontend to apk (policykit policy)"

	mkdir -p "$subpkgdir"/usr/share
	mv "$pkgdir"/usr/share/polkit-1 "$subpkgdir"/usr/share/polkit-1
}

gtk3() {
	# we can only have one or the other :/
	depends="$pkgname-policy"
	conflicts="$pkgname"

	install -Dm755 "$builddir"/apk-gtk.3 "$subpkgdir"/usr/sbin/apk-gtk
	install -Dm644 "$builddir"/apk-gtk.svg "$subpkgdir"/usr/share/apk-gtk/apk-gtk.svg
}

sha512sums="1e620f53f759d4c73edf66505fa17d9034edbe99f75764ba0e3cf75dd292451dd53784f1150cc6c6021e5b2a6e92a0f3cade75b32e6930207b9e60306606561e  apk-gtk-0.1.tar.gz"