aboutsummaryrefslogtreecommitdiffstats
path: root/community/frameworkintegration/APKBUILD
blob: bcf8196f52840737e28fdd6c970d4347d2a0e2b4 (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=frameworkintegration
pkgver=5.78.0
pkgrel=0
pkgdesc="Framework providing components to allow applications to integrate with a KDE Workspace"
arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
url="https://www.kde.org"
license="LGPL-2.1-or-later"
depends_dev="qt5-qtbase-dev kconfig-dev kconfigwidgets-dev kiconthemes-dev knotifications-dev knewstuff-dev kwidgetsaddons-dev kpackage-dev ki18n-dev appstream-dev"
makedepends="$depends_dev extra-cmake-modules"
checkdepends="xvfb-run"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/frameworkintegration-$pkgver.tar.xz"
subpackages="$pkgname-dev"

build() {
	cmake -B build \
		-DCMAKE_BUILD_TYPE=None \
		-DCMAKE_INSTALL_PREFIX=/usr \
		-DCMAKE_INSTALL_LIBDIR=lib
	cmake --build build
}

check() {
	cd build
	CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}

package() {
	DESTDIR="$pkgdir" cmake --build build --target install
}

sha512sums="90737fb7662b483f21bbc12f9661fb3ae9e8a79405c0edaa3e6c5fe83b2a34c0db43a574be1deaf95950ad79e9f40e68813662526eac4ef96dcdf623268aef65  frameworkintegration-5.78.0.tar.xz"