aboutsummaryrefslogtreecommitdiffstats
path: root/community/gns3-server/APKBUILD
blob: 265007eb297697ed0414331bf52118851a5722d7 (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=gns3-server
pkgver=2.2.17
pkgrel=0
pkgdesc="GNS3 network simulator. Server package"
url="https://github.com/GNS3/gns3-server"
arch="all !mips !mips64" # blocked by py3-py-cpuinfo
license="GPL-3.0-or-later"
depends="busybox dynamips python3
	py3-aiohttp-gns3 py3-aiohttp-cors-gns3
	py3-async-timeout-gns3 py3-jsonschema-gns3
	py3-pytest py3-raven
	py3-psutil-gns3 py3-jinja2
	py3-async_generator py3-aiofiles-gns3
	py3-distro py3-py-cpuinfo-gns3 py3-sentry-sdk
	"
makedepends="busybox-static py3-setuptools python3-dev linux-headers"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/GNS3/gns3-server/archive/v$pkgver.tar.gz
requirements.patch"

build() {
	# Upstream includes busybox binary for x86_64. We want to replace it by
	# $CARCH binary
	if [ "$CARCH" != "x86_64" ] ; then
		busybox_bin=$(find . -name busybox -type f)
		cp /bin/busybox.static $busybox_bin
	fi
	python3 setup.py build
}

check() {
	python3 setup.py check
}

package() {
	python3 setup.py install --prefix=/usr --root="$pkgdir"
	mkdir -p "$pkgdir"/usr/share/doc/$pkgname
	cat >"$pkgdir"/usr/share/doc/$pkgname/README.alpine <<EOF
gns3-server has several optional packages that must be installed manually for additional functionality:

	apk add qemu
	apk add wiresark
	apk add ubridge
	apk add cpulimit
	apk add ubridge
	apk add vpcs
EOF
}

sha512sums="233db2e3bb3d6a071ce3ce24b8c86049f2707863f92ca67c4fdfb763bbdc98d3b78a1c2156d2d05548ee10f84394ab333f1c3404723091dc4e7edeb3df5a4a57  gns3-server-2.2.17.tar.gz
673402da09894ce05de40a46c208a2a8b69201febdf3f9eaba440ee4f5b3abedcb6ad3a7a86d9bf60986755292df049f1abc15462c869a099cdd45b0d2461f99  requirements.patch"