aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdelibs4support/APKBUILD
blob: 80bb8f8f5a1b2a6871f004261fdd71a8ce485548 (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdelibs4support
pkgver=5.79.0
pkgrel=0
pkgdesc="Porting aid from KDELibs4"
arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later AND MIT AND LGPL-2.1-only AND LGPL-2.0-only AND (LGPL-2.1-only OR LGPL-3.0-only) AND (LGPL-2.0-only OR LGPL-3.0-only)"
depends_dev="qt5-qtbase-dev qt5-qttools-dev kcompletion-dev kconfig-dev kconfigwidgets-dev kcrash-dev kdesignerplugin kdesignerplugin-dev kglobalaccel-dev kemoticons-dev kguiaddons-dev ki18n-dev kiconthemes-dev kio-dev knotifications-dev kparts-dev kservice-dev ktextwidgets-dev kunitconversion-dev kwidgetsaddons-dev kwindowsystem-dev kxmlgui-dev kdbusaddons-dev kded-dev kinit-dev perl-uri kdoctools-dev kitemmodels-dev"
makedepends="$depends_dev extra-cmake-modules kded"
checkdepends="xvfb-run"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/portingAids/kdelibs4support-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
options="suid !check" # Fails due to requiring running dbus

build() {
	cmake -B build \
		-DCMAKE_BUILD_TYPE=None \
		-DCMAKE_INSTALL_PREFIX=/usr \
		-DCMAKE_INSTALL_LIBDIR=lib
	cmake --build build
}

check() {
	cd build
	CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}


package() {
	DESTDIR="$pkgdir" cmake --build build --target install
}
sha512sums="6bfbded486ce410080eab8fb8c086ca7682cccd8e7328a77950c1801765e9c1e8fdbfbb251b0a718497b46863c9aafe93a9274ca46b2b86bc276cc0ef277c20c  kdelibs4support-5.79.0.tar.xz"