aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdevelop/APKBUILD
blob: 0eb4f8b5ed6303999d085032aa6b4c612491a045 (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdevelop
pkgver=5.5.0
pkgrel=1
arch="all !armhf !ppc64le !s390x !mips !mips64" # Blocked by qt5-qtwebengine
url="https://www.kdevelop.org/"
pkgdesc="A featureful, plugin-extensible IDE for C/C++ and other programming languages"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND GFDL-1.2-only"
depends="indent"
makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtwebengine-dev kconfig-dev
	kdeclarative-dev kdoctools-dev kiconthemes-dev kitemviews-dev kjobwidgets-dev
	kcmutils-dev kio-dev knewstuff-dev knotifyconfig-dev kparts-dev kservice-dev
	ktexteditor-dev threadweaver-dev kxmlgui-dev kwindowsystem-dev kcrash-dev
	kguiaddons-dev karchive-dev knotifications-dev kitemmodels-dev libksysguard-dev
	shared-mime-info grantlee-dev boost-dev libkomparediff2-dev clang-dev clang
	clang-libs"
makedepends="$makedepends llvm-dev" # Should always install the version of llvm that contains /usr/bin/llvm-config
checkdepends="xvfb-run"
source="https://download.kde.org/stable/kdevelop/$pkgver/src/kdevelop-$pkgver.tar.xz
	fix-find-clang-path.patch"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
options="!check" # Broken

build() {
	cmake -B build \
		-DCMAKE_BUILD_TYPE=None \
		-DCMAKE_INSTALL_PREFIX=/usr \
		-DCMAKE_INSTALL_LIBDIR=lib
	make -C build
}

package() {
	DESTDIR="$pkgdir" make -C build install
}

sha512sums="6dcce4c9b124fffbd278279e6b5b9f90dff8b2f90faacd8208256951dcf7ac1ab5ae21610347ab508d3e5df49df3096a6c049271f30b1ed84b0f8401e760380f  kdevelop-5.5.0.tar.xz
6700fcf1da4243aa9950c8c81e47f916d3d04cd11a73fbf14bbe77209fd19000078f49c266d0b58158d7f85cdd89c0316d86284bf665470a5cfb2c8318bdf56d  fix-find-clang-path.patch"