aboutsummaryrefslogtreecommitdiffstats
path: root/community/ki18n/APKBUILD
blob: c753b77e1a5110b7016410b44ecf4c68b6754a7a (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=ki18n
pkgver=5.79.0
pkgrel=0
pkgdesc="Advanced internationalization framework"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-or-later)"
depends_dev="qt5-qtdeclarative-dev qt5-qtscript-dev"
makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/ki18n-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"

build() {
	cmake -B build \
		-DCMAKE_BUILD_TYPE=None \
		-DCMAKE_INSTALL_PREFIX=/usr \
		-DCMAKE_INSTALL_LIBDIR=lib \
		-DBUILD_QCH=ON
	cmake --build build
}

check() {
	cd build
	# ki18n-klocalizedstringtest is broken
	CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "ki18n-klocalizedstringtest"
}


package() {
	DESTDIR="$pkgdir" cmake --build build --target install
}

sha512sums="11caa82ea4bcce074a024595ac5cbd739d368e5e5a3c46d1aa6ab54209a3a70bf3ae795487e8164e2f3c3abb52fea54a709c078899500e59228ba9070bab622e  ki18n-5.79.0.tar.xz"