aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwayland-server/APKBUILD
blob: e49305ade223becd4e7c35b905b0effc80a0bac5 (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kwayland-server
pkgver=5.20.4
pkgrel=0
pkgdesc="Wayland Server Components built on KDE Frameworks"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
url="https://www.kde.org/workspaces/plasmadesktop/"
license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-only"
depends_dev="qt5-qtbase-dev kwayland-dev plasma-wayland-protocols"
makedepends="$depends_dev extra-cmake-modules linux-headers doxygen qt5-qttools-dev wayland-protocols"
source="https://download.kde.org/stable/plasma/$pkgver/kwayland-server-$pkgver.tar.xz"
subpackages="$pkgname-dev"
options="!check" # Requires running wayland compositor

build() {
	cmake -B build \
		-DCMAKE_BUILD_TYPE=None \
		-DCMAKE_INSTALL_PREFIX=/usr \
		-DCMAKE_INSTALL_LIBDIR=lib \
		-DBUILD_QCH=ON
	cmake --build build
}

package() {
	DESTDIR="$pkgdir" cmake --build build --target install
}
sha512sums="a895f52c5705cc57a9f6734755f2e6fa8a04787b3849d28ddfda74ca2994726ac0ef7e2fa10f5a6fa17361173755dad7ba97be33e59be8d0e552128fb60e7b77  kwayland-server-5.20.4.tar.xz"