aboutsummaryrefslogtreecommitdiffstats
path: root/community/lasem/APKBUILD
blob: 52da68b4b25fd25cfade78501ee956ef0ce49b34 (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=lasem
pkgver=0.5.1
_apiver=0.6
pkgrel=0
pkgdesc="A library for rendering SVG and Mathml, implementing a DOM like API"
url="https://wiki.gnome.org/Projects/Lasem"
arch="all !aarch64 !s390x" # Test fails on limited arches
license="LGPL-2.0 GPL-2.0"
makedepends="intltool gdk-pixbuf-dev gobject-introspection-dev libxml2-dev
	pango-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-render"
source="https://download.gnome.org/sources/lasem/${pkgver%.*}/lasem-$pkgver.tar.xz
	install-mathml-headers.patch"
builddir="$srcdir/$pkgname-$pkgver"

build() {
	cd "$builddir"

	./configure \
		--build=$CBUILD \
		--host=$CHOST \
		--prefix=/usr \
		--mandir=/usr/share/man \
		--localstatedir=/var \
		--disable-silent-rules \
		|| return 1
	make
}

check() {
	cd "$builddir"
	make check
}

package() {
	cd "$builddir"

	make DESTDIR="$pkgdir" install || return 1

	# Some software expect pkg-config name without a version.
	test -e "$pkgdir"/usr/lib/pkgconfig/$pkgname-$_apiver.pc
	ln -s $pkgname-$_apiver.pc "$pkgdir"/usr/lib/pkgconfig/$pkgname.pc

	rm -r "$pkgdir"/usr/share/gtk-doc \
		"$pkgdir"/usr/doc
}

render() {
	pkgdesc="Simple MathML converter"

	cd "$pkgdir"

	mkdir -p "$subpkgdir"/usr/bin
	mv usr/bin/lasem-render* "$subpkgdir"/usr/bin/
	rmdir usr/bin || true

	test -e "$subpkgdir"/usr/bin/lasem-render-$_apiver
	ln -s lasem-render-$_apiver "$subpkgdir"/usr/bin/lasem-render
}

sha512sums="81186e85a5d5eaebb30f215660181207f4c6a49be7f50c9668dfca72392457ef98c629196c343b8b3db6362bf0d13d4fbd4107f23364adcff8d24f433564fcac  lasem-0.5.1.tar.xz
bdfa5cd2b108d40ec77cee70f5bf2664a003b75249078fe57a8ddffb51a01f0ac8194fbec1ebc000a0aa4a65b08647874ed317bfa4523e24db59f49ca66d34eb  install-mathml-headers.patch"