aboutsummaryrefslogtreecommitdiffstats
path: root/community/mapplauncherd-qt/APKBUILD
blob: d90edce6e11e3c2c06f5dfd5766453251256a231 (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=mapplauncherd-qt
pkgver=1.1.17
pkgrel=2
pkgdesc="Application launch boosters for Qt5"
url="https://git.sailfishos.org/mer-core/mapplauncherd-qt"
arch="all !armhf" # blocked by mapplauncherd
license="LGPL-2.1-only"
depends_dev="
	libxml2-dev
	mapplauncherd-dev
	qt5-qtbase-dev
	qt5-qtdeclarative-dev
	"
makedepends="$depends_dev"
subpackages="$pkgname-dev"
source="https://git.sailfishos.org/mer-core/mapplauncherd-qt/-/archive/$pkgver/mapplauncherd-qt-$pkgver.tar.gz"
options="!check" # No tests

build() {
	qmake-qt5 \
		PREFIX=/usr
	make
}

package() {
	INSTALL_ROOT="$pkgdir" make install

	# We don't ship systemd
	rm -r "$pkgdir"/usr/lib/systemd
}
sha512sums="da9be4f6c121927627ef2a18e07c82a5973bc3a8086e49955677a44c13673a78eef441b159b7d6c43003564fa12d1f8b3e93ed2917baf3a1e0dd36c37da950fe  mapplauncherd-qt-1.1.17.tar.gz"