aboutsummaryrefslogtreecommitdiffstats
path: root/community/postgresql-orafce/APKBUILD
blob: 2143da8daee8f9ef811dcdb8d1b84759e77fb43b (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=postgresql-orafce
_pkgname=orafce
pkgver=3.18.1
_pkgver=VERSION_${pkgver//./_}
pkgrel=0
pkgdesc="Oracle's compatibility functions and packages for PostgreSQL"
url="https://github.com/orafce/orafce"
arch="all"
license="0BSD"
makedepends="bison flex postgresql-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/orafce/$_pkgname/archive/$_pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$_pkgver"
options="!check"  # XXX: installcheck requires running PostgreSQL

build() {
	make USE_PGXS=1 all
}

package() {
	_pgver=$(pg_config --major-version)
	depends="postgresql$_pgver"

	make USE_PGXS=1 DESTDIR="$pkgdir" install

	cd "$pkgdir"
	mv ./usr/share/doc/postgresql$_pgver/extension \
		./usr/share/doc/$pkgname
	rmdir ./usr/share/doc/postgresql$_pgver
}

sha512sums="
f549fb50b843c6f7f6f09e215b53cb5f3fb2ce8749a7590c5959c9a36a7072384d7c59fed9f6618bdc6fdfbe475a199c61e274937f39cd2cfea6c4de9de805c6  postgresql-orafce-3.18.1.tar.gz
"