aboutsummaryrefslogtreecommitdiffstats
path: root/community/postgresql-orafce/APKBUILD
blob: 3648d785a7ca2eb61a3a451c524f846b14bad2a8 (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=postgresql-orafce
_pkgname=orafce
pkgver=3.6.1
_pkgver=VERSION_${pkgver//./_}
pkgrel=1
pkgdesc="Oracle's compatibility functions and packages for PostgreSQL"
url="https://github.com/orafce/orafce"
arch="all"
license="BSD"
depends="postgresql"
makedepends="bison flex postgresql-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/orafce/$_pkgname/archive/$_pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$_pkgver"
options="!check"  # XXX: installcheck requires running PostgreSQL

build() {
	cd "$builddir"
	make USE_PGXS=1 all
}

package() {
	cd "$builddir"

	make USE_PGXS=1 DESTDIR="$pkgdir" install

	cd "$pkgdir"
	mv ./usr/share/doc/postgresql/extension \
		./usr/share/doc/$pkgname
	rmdir ./usr/share/doc/postgresql
}

sha512sums="330e0147087375e65c224dd357cb6f369fe0c723e3f6024b4820c0792acf6f2459744a1003001f3048a4c75212a018f69ec5d3f6aca138eda75a95f9e3e9f039  postgresql-orafce-3.6.1.tar.gz"