aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-snmp/remove-bogus-check.patch
blob: 4ce19a0c2f4ab8e4f00482005bae9c7168fbd088 (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
diff --git a/setup.py b/setup.py
index 0d987d5..82da3ad 100644
--- a/setup.py
+++ b/setup.py
@@ -63,19 +63,6 @@ try:
 
     setup, Command = setuptools.setup, setuptools.Command
 
-    observed_version = [int(x) for x in setuptools.__version__.split('.')]
-    required_version = [36, 2, 0]
-
-    # NOTE(etingof): require fresh setuptools to build proper wheels
-    # See also: https://hynek.me/articles/conditional-python-dependencies/
-    if ('bdist_wheel' in sys.argv and
-            observed_version < required_version):
-        print("ERROR: your wheels won't come out round with setuptools %s! "
-              "Upgrade to %s and try again." % (
-                '.'.join([str(x) for x in observed_version]),
-                '.'.join([str(x) for x in required_version])))
-        sys.exit(1)
-
     params = {
         'install_requires': requires,
         'zip_safe': True