aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qt5compat/APKBUILD
blob: fb6711474c28ad61cd25c9f01687cdcf535224dc (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=qt6-qt5compat
pkgver=6.2.0
pkgrel=1
pkgdesc="Module that contains unsupported Qt 5 APIs"
url="https://qt.io/"
arch="all"
license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
depends_dev="
	qt6-qtbase-dev
	"
makedepends="$depends_dev
	cmake
	perl
	"
subpackages="$pkgname-dev"
options="!check" # No tests
builddir="$srcdir/qt5compat-everywhere-src-${pkgver/_/-}"

case $pkgver in
	*_alpha*|*_beta*|*_rc*) _rel=development_releases;;
	*) _rel=official_releases;;
esac

source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qt5compat-everywhere-src-${pkgver/_/-}.tar.xz"

build() {
	cmake -B build \
		-DCMAKE_BUILD_TYPE=None \
		-DCMAKE_INSTALL_PREFIX=/usr
	cmake --build build
}

package() {
	DESTDIR="$pkgdir" cmake --install build
}

sha512sums="
25bdaae61a5a5203c940a4fc7eb7c3aa61282f0cdcf716e2f20d264e6bb271117ef4a1724ca17c44dbabd6c62fcf78af4495b1c6f142151414d5d071f5378030  qt5compat-everywhere-src-6.2.0.tar.xz
"