aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libvmime/APKBUILD
blob: 316c3dfc01d737c4600a0438fdd6682cd76ef66b (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
# Maintainer: Noel Kuntze <noel.kuntze@thermi.consulting>
pkgname=libvmime
pkgver=0.9.2k4
pkgrel=5
pkgdesc="Library for working with RFC 5322, MIME messages and IMAP/POP/SMTP"
arch="all"
url="https://www.vmime.org/"
license="GPL-3.0-only"
# cmake config file isn't suitable for explicitely setting the TLS lib when it finds gnutls
makedepends="libgsasl-dev openssl-dev cmake gtk+3.0-dev doxygen
	cppunit-dev graphviz !gnutls-dev samurai"
subpackages="$pkgname-dbg $pkgname-dev"
source="libvmime-$pkgver.tar.gz::https://github.com/Kopano-dev/vmime/archive/v$pkgver.tar.gz
	fix-icu-70-1.patch
	"

builddir="$srcdir/vmime-$pkgver"

# can't build in other directory because cmake config is broken here.
# library will not exist at package time.
build() {
	cmake -B . -G Ninja \
		-DCMAKE_BUILD_TYPE=MinSizeRel \
		-DCMAKE_INSTALL_PREFIX=/usr/ \
		-DVMIME_BUILD_TESTS=ON \
		-DVMIME_TLS_SUPPORT_LIB=openssl
	cmake --build .
}

check() {
	LANG=C.UTF-8 build/bin/run-tests
}

package() {
	DESTDIR="$pkgdir" cmake --install .
	mv "$pkgdir/usr/cmake" "$pkgdir/usr/lib/cmake"
}

sha512sums="
90ebce51151944fe9cf09a8385b4ffe4db199c87e79579f66d70221f45a4bf4b048f3115077cff83536119af40ebe89eddacc301b54b7fb017438f44bd0f273c  libvmime-0.9.2k4.tar.gz
65c0c1ec56a9a56167bb8b18e01feee4ea65fa958f5e2f233aa13d0472a803574d8b2751b2e6011edcd1db119f91c66e2401fd4916eecbb3af04dc2e527c125c  fix-icu-70-1.patch
"