aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorfossdd <fossdd@pwned.life>2024-04-16 16:26:59 +0200
committerJakub Jirutka <jakub@jirutka.cz>2024-04-19 20:51:57 +0000
commit9981ba3abc40c6a5a2bde848ac8082479deef9c2 (patch)
treea5cfa87afffee690f2102cc4eb9af67cb29c7807
parent3ada19fa945bcb4f1c7bdf1e0a5a36573a1eeda0 (diff)
testing/waylock: upgrade to 1.0.0HEADmaster
https://codeberg.org/ifreund/waylock/releases/tag/v1.0.0
-rw-r--r--testing/waylock/APKBUILD6
-rw-r--r--testing/waylock/fix-version-string.patch15
2 files changed, 2 insertions, 19 deletions
diff --git a/testing/waylock/APKBUILD b/testing/waylock/APKBUILD
index 8ec016c3be8..b15f8173f38 100644
--- a/testing/waylock/APKBUILD
+++ b/testing/waylock/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=waylock
-pkgver=0.6.5
+pkgver=1.0.0
pkgrel=0
pkgdesc="A small screenlocker for Wayland compositors"
url="https://codeberg.org/ifreund/waylock"
@@ -17,7 +17,6 @@ makedepends="
"
subpackages="$pkgname-doc"
source="https://codeberg.org/ifreund/waylock/releases/download/v$pkgver/waylock-$pkgver.tar.gz
- fix-version-string.patch
pam-base-auth.patch
"
@@ -37,7 +36,6 @@ package() {
}
sha512sums="
-1a158205c12c51946178ede06eded9f54aff03aefdb5c3e306b1570ef786a611405cfcb96bafb4bd29a82016077fce0630c406d56431ad7dc5cbfb9a5696b589 waylock-0.6.5.tar.gz
-c1782ce8f6e2a2eab4bc5cdfdba22e0e9b14e89c319737bd0c331a9b8c4b09cc9debafa33c6936631f6db14331ebecf0d327dc05d8c8a77a36ef45de35639750 fix-version-string.patch
+ceb5920c1ca3e7e46185e8f438a73fecc4245bf1293628775998d4b1e1dbf5cf682ffff9ca6e801135873cf278ae2fccedb3dc418641db3bac282047fccce4cb waylock-1.0.0.tar.gz
e3f5aa479908babbeea2febecdf7c57a5cf6b9153c4cd63731721cdf6d50bd0417077b37effec1520064918a422c4313d24ee9c2b2a77c328be931ffbeb03161 pam-base-auth.patch
"
diff --git a/testing/waylock/fix-version-string.patch b/testing/waylock/fix-version-string.patch
deleted file mode 100644
index d2d345f3fce..00000000000
--- a/testing/waylock/fix-version-string.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-This is a bug with the waylock 0.6.5 release tarball. The Git tag for 0.6.5
-does not have this problem. This patch can be removed on the next release.
-
-diff -upr waylock-0.6.5.orig/build.zig waylock-0.6.5/build.zig
---- waylock-0.6.5.orig/build.zig 2024-03-03 10:47:47.439903112 +0100
-+++ waylock-0.6.5/build.zig 2024-03-03 10:47:55.963263085 +0100
-@@ -10,7 +10,7 @@ const Scanner = @import("deps/zig-waylan
- /// development with the "-dev" suffix.
- /// When a release is tagged, the "-dev" suffix should be removed for the commit that gets tagged.
- /// Directly after the tagged commit, the version should be bumped and the "-dev" suffix added.
--const version = "0.6.6-dev";
-+const version = "0.6.5";
-
- pub fn build(b: *Build) !void {
- const target = b.standardTargetOptions(.{});