aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoromni <omni+alpine@hack.org>2024-04-16 03:17:24 +0000
committeromni <omni+alpine@hack.org>2024-04-16 11:11:02 +0000
commit02647ca1bf0724b1dae193a25ede6d83af4dfced (patch)
tree36625802bd4d74563b8974daaaf48a9d8ef811ec
parent97044f9a75bf799e53b00fa1b1d2990563256da2 (diff)
testing/ruff-lsp: upgrade to 0.0.53HEADmaster
- enable on all architectures - rebuild against python 3.12
-rw-r--r--testing/ruff-lsp/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/testing/ruff-lsp/APKBUILD b/testing/ruff-lsp/APKBUILD
index 986d40690f4..4185ae44782 100644
--- a/testing/ruff-lsp/APKBUILD
+++ b/testing/ruff-lsp/APKBUILD
@@ -1,11 +1,10 @@
# Maintainer: Hugo Osvaldo Barrera <hugo@whynothugo.nl>
pkgname=ruff-lsp
-pkgver=0.0.51
+pkgver=0.0.53
pkgrel=0
pkgdesc="Language Server Protocol implementation for Ruff"
url="https://github.com/charliermarsh/ruff-lsp"
-# ruff
-arch="aarch64 x86_64"
+arch="all"
license="MIT"
depends="
py3-gls
@@ -16,7 +15,7 @@ depends="
makedepends="py3-gpep517 py3-installer py3-hatchling"
checkdepends="py3-lsp-jsonrpc py3-pytest"
subpackages="$pkgname-pyc"
-source="https://github.com/charliermarsh/ruff-lsp/archive/v$pkgver/ruff-lsp-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/astral-sh/ruff-lsp/archive/refs/tags/v$pkgver.tar.gz"
options="!check" # no tests ran
build() {
@@ -26,7 +25,9 @@ build() {
}
check() {
- python3 -m unittest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m unittest
}
package() {
@@ -35,5 +36,5 @@ package() {
}
sha512sums="
-1e9554a93abb199ec3bc96675fa12a8907ec150f5bb0fce925aa7e8074009c097f725c6f6a72f1f485342af69985e6c067a8deb061d22a4c3ec987eeef244cde ruff-lsp-0.0.51.tar.gz
+a5a14299486943dec3143e54424b631acee619d3d88449de44c4d8167dd7776e2191a8873585acf40959d22f733a7196e275e58a6b4f0919fe8e2858e2d07414 ruff-lsp-0.0.53.tar.gz
"