aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSertonix <sertonix@posteo.net>2024-04-13 20:53:11 +0200
committerJ0WI <1715-J0WI@users.gitlab.alpinelinux.org>2024-04-19 00:05:41 +0000
commit8abdd4e0df7233a8ce5956cac6b5e8bd55ae52c6 (patch)
treec43ffb4c3e326969006789a735540f8c89ed0c29
parented9ada7f6d2a21c10874543c088dbd4a88dda214 (diff)
main/gptfdisk: modernizeHEADmaster
Also removes the executable flag from the man pages
-rw-r--r--main/gptfdisk/APKBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/main/gptfdisk/APKBUILD b/main/gptfdisk/APKBUILD
index ef3d6d29525..3f63c691243 100644
--- a/main/gptfdisk/APKBUILD
+++ b/main/gptfdisk/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gptfdisk
pkgver=1.0.10
-pkgrel=0
+pkgrel=1
pkgdesc="Text-mode partitioning tool that works on Globally Unique Identifier (GUID) Partition Table (GPT) disks"
arch="all"
url="https://www.rodsbooks.com/gdisk"
@@ -22,11 +22,8 @@ build() {
}
package() {
- mkdir -p "$pkgdir"/usr/bin "$pkgdir"/usr/share/man/man8
- local i; for i in gdisk cgdisk sgdisk fixparts; do
- install $i "$pkgdir"/usr/bin/
- install $i.8 "$pkgdir"/usr/share/man/man8/
- done
+ install -Dm0644 -t "$pkgdir"/usr/share/man/man8 ./*.8
+ install -Dm0755 -t "$pkgdir"/usr/bin gdisk cgdisk sgdisk fixparts
}
check() {
@@ -35,8 +32,8 @@ check() {
sgdisk() {
pkgdesc="Command-line GUID partition table (GPT) manipulator"
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/sgdisk "$subpkgdir"/usr/bin/
+
+ amove usr/bin/sgdisk
}
sha512sums="