aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Brust <tim.brust@sinnerschrader.com>2018-11-28 18:14:01 +0100
committerAndy Postnikov <apostnikov@gmail.com>2018-12-06 02:41:25 +0200
commitd30e50323c5f1784719c4be7a9c21388b2ac6dcb (patch)
tree6a18e0aa1b25e264ace1d3d77cc994a7e6f13e44
parentc74c49e3ab3060e7d541fa7272af2fa4a5404f78 (diff)
downloadaports-d30e50323c5f1784719c4be7a9c21388b2ac6dcb.tar.bz2
community/nodejs-current: upgrade to 11.3.0
-rw-r--r--community/nodejs-current/APKBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/community/nodejs-current/APKBUILD b/community/nodejs-current/APKBUILD
index 94ca508..bb5f7b5 100644
--- a/community/nodejs-current/APKBUILD
+++ b/community/nodejs-current/APKBUILD
@@ -2,6 +2,12 @@
# Maintainer: Jose-Luis Rivas <ghostbar@riseup.net>
#
# secfixes:
+# 11.3.0-r0:
+# - CVE-2018-12121
+# - CVE-2018-12122
+# - CVE-2018-12123
+# - CVE-2018-0735
+# - CVE-2018-0734
# 9.10.0-r0:
# - CVE-2018-7158
# - CVE-2018-7159
@@ -12,7 +18,7 @@
#
pkgname=nodejs-current
# The current stable version, i.e. non-LTS.
-pkgver=11.1.0
+pkgver=11.3.0
pkgrel=0
pkgdesc="JavaScript runtime built on V8 engine - current stable version"
url="https://nodejs.org/"
@@ -78,5 +84,5 @@ package() {
rm "$pkgdir"/usr/bin/npm "$pkgdir"/usr/bin/npx
}
-sha512sums="ba4c3c895f69e01e76c900ae0ca92463d1ecdabbe567954dd84338c4786203716ce561bf4ae64057d4091b8032ae4a87f5d50d7e6e94784e282078dd44c97a12 node-v11.1.0.tar.gz
+sha512sums="dd1475bd61dbc2aac563e12ced0b9423bf1f5fc421d0699526799b60254d89cbb8d01530f2f029fe146777aecadc4aa54ad62d7b33fb9195f16d8a54b1278588 node-v11.3.0.tar.gz
9145a28bc3c2ebfc5e29e7416f8387a68808607eea4d87830a14a27c80628177a02ef4ed54b0efe2384c39fedf7356d12c267567d06d53d669c55d6211bfcf8a dont-run-gyp-files-for-bundled-deps.patch"