aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorznley <shanjiantao@loongson.cn>2024-03-29 03:10:36 +0000
committerBart Ribbers <bribbers@disroot.org>2024-04-18 06:38:23 +0000
commit81b14ae4eed038662b53cd20786fd5e0816279ec (patch)
tree8646b15d60c4544f261bd841cac97d6613c9d4e6
parentf916ac50b95095725635626148f46a27d14b9d56 (diff)
community/qt5-qtbase: add loongarch64 supportHEADmaster
-rw-r--r--community/qt5-qtbase/APKBUILD2
-rw-r--r--community/qt5-qtbase/loongarch64.patch12
2 files changed, 14 insertions, 0 deletions
diff --git a/community/qt5-qtbase/APKBUILD b/community/qt5-qtbase/APKBUILD
index 12909e9218e..43aec5bee09 100644
--- a/community/qt5-qtbase/APKBUILD
+++ b/community/qt5-qtbase/APKBUILD
@@ -71,6 +71,7 @@ source="https://dev.alpinelinux.org/archive/qt/$_fullname.tar.xz
qt5-base-cflags.patch
qt5-base-nostrip.patch
fix-build-with-xkbcommon-160.patch
+ loongarch64.patch
"
builddir="$srcdir/$_fullname"
@@ -264,4 +265,5 @@ d5bd9ace2cc15a96c3266603be067620f1a31d8e2636f2bdd6ee9d03d03329af0b86b823f5d35645
fa3dddfe42b7f0ade45bd0530badfc3a3800adbd3798bd814597527713c9fe360a242f7cf39312f4cc3c88e9bd7aba233bd6674c0fc78e694a1fd868474c4240 qt5-base-cflags.patch
af061bb56d5079d11407e6eb352fa4af7fefa6aed7f8cc40b5b2d591ef7ff04e9da6c6d534ca1904355ea7552951a1610fdcefb04ef9d696cb2b23ad6a0606e8 qt5-base-nostrip.patch
1f97b8ac068df2169c114a44e277faec66e4b353a024c328dd506c6ca1270d124f84a61c0c5cf45f7458a6d702570bf7fcdd70e0ce2d040d0b4a8f4cf59d8776 fix-build-with-xkbcommon-160.patch
+7f0a3f255e25b47b1a45632207f6c0b506119b9cf84edcf1bc02c1a31c4487d1b52359861a731522613f32147890c171446a9c05f166dcf97c046a45964e03d1 loongarch64.patch
"
diff --git a/community/qt5-qtbase/loongarch64.patch b/community/qt5-qtbase/loongarch64.patch
new file mode 100644
index 00000000000..37257685c29
--- /dev/null
+++ b/community/qt5-qtbase/loongarch64.patch
@@ -0,0 +1,12 @@
+diff --git a/src/3rdparty/double-conversion/include/double-conversion/utils.h b/src/3rdparty/double-conversion/include/double-conversion/utils.h
+index 70e697ca..4b606dd9 100644
+--- a/src/3rdparty/double-conversion/include/double-conversion/utils.h
++++ b/src/3rdparty/double-conversion/include/double-conversion/utils.h
+@@ -94,6 +94,7 @@ int main(int argc, char** argv) {
+ defined(__ARMEL__) || defined(__avr32__) || defined(_M_ARM) || defined(_M_ARM64) || \
+ defined(__hppa__) || defined(__ia64__) || \
+ defined(__mips__) || \
++ defined(__loongarch__) || \
+ defined(__powerpc__) || defined(__ppc__) || defined(__ppc64__) || \
+ defined(_POWER) || defined(_ARCH_PPC) || defined(_ARCH_PPC64) || \
+ defined(__sparc__) || defined(__sparc) || defined(__s390__) || \