aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/libunwind/APKBUILD2
-rw-r--r--main/libunwind/Remove-the-useless-endina.h-for-loongarch64.patch25
2 files changed, 27 insertions, 0 deletions
diff --git a/main/libunwind/APKBUILD b/main/libunwind/APKBUILD
index 5775db0fcd2..1f68817aa69 100644
--- a/main/libunwind/APKBUILD
+++ b/main/libunwind/APKBUILD
@@ -16,6 +16,7 @@ subpackages="$pkgname-dbg $pkgname-static $pkgname-dev $pkgname-doc"
source="https://github.com/libunwind/libunwind/releases/download/v$pkgver/libunwind-$pkgver.tar.gz
force-enable-man.patch
fix-libunwind-pc-in.patch
+ Remove-the-useless-endina.h-for-loongarch64.patch
"
build() {
@@ -45,4 +46,5 @@ sha512sums="
aba7b578c1b8cbe78f05b64e154f3530525f8a34668b2a9f1ee6acb4b22c857befe34ad4e9e8cca99dbb66689d41bc72060a8f191bd8be232725d342809431b3 libunwind-1.8.1.tar.gz
2d210a2d8e960610e515d8cf9ebd388faa30a4f35613cae6a40a06e1ca1267540b974e96a9d94c02c465d47e114d3d3d6cbad72b4c1dbd0eb53d812970b1712d force-enable-man.patch
ab5d44e9d3aaf32e3119fe79389e5dfcdc859c78cfda8400e54ee29fd1cdf04b99e2686caf18ab0b76ac94f861861d69a5cf740d46967af9c630095485523f1c fix-libunwind-pc-in.patch
+db8ab626920fa7fea5f0ff17e92909f0b293804eca61425dff53dd79a0f92b4db80941850fa144cfc9ecd2e1537b26fa8d62c56824ffea8e2790ed3930c8ff96 Remove-the-useless-endina.h-for-loongarch64.patch
"
diff --git a/main/libunwind/Remove-the-useless-endina.h-for-loongarch64.patch b/main/libunwind/Remove-the-useless-endina.h-for-loongarch64.patch
new file mode 100644
index 00000000000..eef66128174
--- /dev/null
+++ b/main/libunwind/Remove-the-useless-endina.h-for-loongarch64.patch
@@ -0,0 +1,25 @@
+From 44359b80a85cc2fa5bcb7c9c82d68a94fca3bd33 Mon Sep 17 00:00:00 2001
+From: Jingyun Hua <huajingyun@loongson.cn>
+Date: Mon, 8 Apr 2024 15:57:15 +0800
+Subject: [PATCH] Remove the useless endina.h in getcontext.S for loongarch64
+
+Fix issue #740
+---
+ src/loongarch64/getcontext.S | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/loongarch64/getcontext.S b/src/loongarch64/getcontext.S
+index 3344fc2e..c568832c 100644
+--- a/src/loongarch64/getcontext.S
++++ b/src/loongarch64/getcontext.S
+@@ -25,7 +25,6 @@ OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
+ WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. */
+
+ #include "offsets.h"
+-#include <endian.h>
+ .text
+
+ #define SREG(X) st.d $r##X, $r4, (LINUX_UC_MCONTEXT_GREGS + 8 * X)
+--
+2.27.0
+