aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/hare/APKBUILD6
-rw-r--r--community/hare/hare-rv64-fix.patch25
2 files changed, 28 insertions, 3 deletions
diff --git a/community/hare/APKBUILD b/community/hare/APKBUILD
index d1fe995a85a..a3a6589d535 100644
--- a/community/hare/APKBUILD
+++ b/community/hare/APKBUILD
@@ -12,8 +12,8 @@ checkdepends="tzdata"
subpackages="$pkgname-doc"
source="
$pkgname-$pkgver.tar.gz::https://git.sr.ht/~sircmpwn/hare/archive/$pkgver.tar.gz
- $pkgname-rv64-fix.patch::https://git.sr.ht/~sircmpwn/hare/commit/80e45e4d931a6e90d999846b86471cac00d2a6d5.patch
-"
+ $pkgname-rv64-fix.patch
+ "
build() {
cp configs/linux.mk config.mk
@@ -30,5 +30,5 @@ package() {
sha512sums="
d7b96bc031d432e0ca0a9186a043d4cd4af4d4b57be5ce4b913d6acd26cdb708d8c9ad8e2c64c78c192a11a96977d3e916985a548238591b3c4d177b9cc811d9 hare-0.24.0.tar.gz
-6e38375cc4b7c6d316e6d42deb285d2245256307aaafb3dad985be1bbeaa82ecadc9bdcc99505156fb4f398f96123ca48e136cbd23c6f39a539cd684c1fff97a hare-rv64-fix.patch
+8982c00cab8449220c0871b60c603e50aaf7b5a2c3015a4ea6d2fad57bcd944203db15e536725f322bcbdf4494fdf39d586d6ddf3c7e11f2c8e0c6461986b974 hare-rv64-fix.patch
"
diff --git a/community/hare/hare-rv64-fix.patch b/community/hare/hare-rv64-fix.patch
new file mode 100644
index 00000000000..19fceb51d85
--- /dev/null
+++ b/community/hare/hare-rv64-fix.patch
@@ -0,0 +1,25 @@
+From 80e45e4d931a6e90d999846b86471cac00d2a6d5 Mon Sep 17 00:00:00 2001
+From: Andreas Schwab <schwab@suse.de>
+Date: Wed, 21 Feb 2024 22:05:02 +0100
+Subject: [PATCH] debug+riscv: use correct comment syntax
+
+Signed-off-by: Andreas Schwab <schwab@suse.de>
+---
+ debug/+riscv64/getfp.s | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/debug/+riscv64/getfp.s b/debug/+riscv64/getfp.s
+index 9c3698af..b822036a 100644
+--- a/debug/+riscv64/getfp.s
++++ b/debug/+riscv64/getfp.s
+@@ -1,5 +1,5 @@
+-// SPDX-License-Identifier: MPL-2.0
+-// (c) Hare authors <https://harelang.org>
++# SPDX-License-Identifier: MPL-2.0
++# (c) Hare authors <https://harelang.org>
+
+ .section ".text.debug.getfp","ax"
+ .global debug.getfp
+--
+2.43.0
+