aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/matrix2051/APKBUILD (renamed from testing/matrix2051/APKBUILD)13
-rw-r--r--community/matrix2051/matrix2051.initd (renamed from testing/matrix2051/matrix2051.initd)0
-rw-r--r--community/matrix2051/no-erts.patch (renamed from testing/matrix2051/no-erts.patch)0
-rw-r--r--community/matrix2051/pantalaimon.patch (renamed from testing/matrix2051/pantalaimon.patch)0
4 files changed, 3 insertions, 10 deletions
diff --git a/testing/matrix2051/APKBUILD b/community/matrix2051/APKBUILD
index 58645f1a20b..3c05b148d36 100644
--- a/testing/matrix2051/APKBUILD
+++ b/community/matrix2051/APKBUILD
@@ -29,16 +29,9 @@ export ERL_LIBS="/usr/lib/erlang/lib"
prepare() {
default_prepare
- # Precompiled hex doesn't work on aarch64 when using Erlang 26.2.3
- # Apply workaround mentioned in https://elixirforum.com/t/62154/9
- if [ "$CARCH" = "aarch64" ]; then
- msg "Recompiling hex"
- mix archive.install --force github hexpm/hex tag v2.0.6
- else
- msg "Using precompiled hex"
- mix local.hex --force
- fi
-
+ msg "Using precompiled hex"
+ mix local.hex --force
+ msg "Using system rebar3"
mix local.rebar --force rebar3 /usr/bin/rebar3
mix deps.get --only prod
diff --git a/testing/matrix2051/matrix2051.initd b/community/matrix2051/matrix2051.initd
index 30593bbc517..30593bbc517 100644
--- a/testing/matrix2051/matrix2051.initd
+++ b/community/matrix2051/matrix2051.initd
diff --git a/testing/matrix2051/no-erts.patch b/community/matrix2051/no-erts.patch
index f29c867013a..f29c867013a 100644
--- a/testing/matrix2051/no-erts.patch
+++ b/community/matrix2051/no-erts.patch
diff --git a/testing/matrix2051/pantalaimon.patch b/community/matrix2051/pantalaimon.patch
index a1b1c277047..a1b1c277047 100644
--- a/testing/matrix2051/pantalaimon.patch
+++ b/community/matrix2051/pantalaimon.patch