aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/waybar/0001-upower-fix-segfault-by-initializing-lastWarningLevel.patch26
-rw-r--r--community/waybar/APKBUILD4
2 files changed, 29 insertions, 1 deletions
diff --git a/community/waybar/0001-upower-fix-segfault-by-initializing-lastWarningLevel.patch b/community/waybar/0001-upower-fix-segfault-by-initializing-lastWarningLevel.patch
new file mode 100644
index 00000000000..5803a18c2fc
--- /dev/null
+++ b/community/waybar/0001-upower-fix-segfault-by-initializing-lastWarningLevel.patch
@@ -0,0 +1,26 @@
+From 3b507d63a07ab198d6499b5a49663bcc9346dcf0 Mon Sep 17 00:00:00 2001
+From: Clayton Craft <clayton@craftyguy.net>
+Date: Wed, 24 Apr 2024 23:51:32 -0700
+Subject: [PATCH] upower: fix segfault by initializing lastWarningLevel
+
+fixes bd8b215416cdca6ed0c929c18cede7dfb907edf0
+---
+ include/modules/upower/upower.hpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/modules/upower/upower.hpp b/include/modules/upower/upower.hpp
+index 8cea8c42..a5eb7209 100644
+--- a/include/modules/upower/upower.hpp
++++ b/include/modules/upower/upower.hpp
+@@ -71,7 +71,7 @@ class UPower : public AModule {
+ GDBusConnection *login1_connection;
+ std::unique_ptr<UPowerTooltip> upower_tooltip;
+ std::string lastStatus;
+- const char *lastWarningLevel;
++ const char *lastWarningLevel = nullptr;
+ bool showAltText;
+ bool showIcon = true;
+ bool upowerRunning;
+--
+2.44.0
+
diff --git a/community/waybar/APKBUILD b/community/waybar/APKBUILD
index daba2a7abf3..8e849f068f1 100644
--- a/community/waybar/APKBUILD
+++ b/community/waybar/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Clayton Craft <clayton@craftyguy.net>
pkgname=waybar
pkgver=0.10.2
-pkgrel=1
+pkgrel=2
pkgdesc="Highly customizable Wayland bar for Sway and Wlroots based compositors"
url="https://github.com/Alexays/Waybar/"
# s390x: no wireplumber (but who uses it there anyway)
@@ -32,6 +32,7 @@ makedepends="
subpackages="$pkgname-doc"
source="https://github.com/Alexays/Waybar/archive/$pkgver/Waybar-$pkgver.tar.gz
config-fix-clock.patch
+ 0001-upower-fix-segfault-by-initializing-lastWarningLevel.patch
"
options="!check" # No test suite
builddir="$srcdir/Waybar-$pkgver"
@@ -64,4 +65,5 @@ package() {
sha512sums="
2ddcdc6cc7a41d4d9e06d7002aa501201a75350a114c86a931352c1dee1b0f435b06b5b534a92c3aa4771093932d43d0f1150a659561af39b9c3d98dcbed7724 Waybar-0.10.2.tar.gz
cd6fea7e9981e13ecb911da66b4f22e949542d4085d696e01d8d4eac0986e0ab15d5c1430040b76be730437a586dbe1f5c49ac8435269e6310fb2c213b6c74a2 config-fix-clock.patch
+ecac14b9c6d0e27e89f0a4a4eed0f0ddefa136dfbc9d80187efea770064583d0f014ac6acb12e95aac4dc98f9acd93c0ade0039356a1b1e9ba420924633abcea 0001-upower-fix-segfault-by-initializing-lastWarningLevel.patch
"