aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/font-noto-cjk/APKBUILD2
-rw-r--r--community/hashcash/APKBUILD1
-rw-r--r--community/py3-deepdiff/APKBUILD2
-rw-r--r--testing/pcsc-perl/APKBUILD3
4 files changed, 2 insertions, 6 deletions
diff --git a/community/font-noto-cjk/APKBUILD b/community/font-noto-cjk/APKBUILD
index c091e7b38ed..f1174b6d261 100644
--- a/community/font-noto-cjk/APKBUILD
+++ b/community/font-noto-cjk/APKBUILD
@@ -11,7 +11,7 @@ arch="noarch"
license="OFL-1.1"
depends="fontconfig"
subpackages="$pkgname-extra:_extra"
-source="https://dev.alpinelinux.org/archive/font-noto-cjk/$pkgname-$pkgver.tar.xz"
+source="https://dev.alpinelinux.org/archive/font-noto-cjk/font-noto-cjk-$pkgver.tar.xz"
options="!check" # font
# the git repo tarballs don't give any fonts (?),
diff --git a/community/hashcash/APKBUILD b/community/hashcash/APKBUILD
index 4e28ef2a8d1..aa0671b78d2 100644
--- a/community/hashcash/APKBUILD
+++ b/community/hashcash/APKBUILD
@@ -9,7 +9,6 @@ arch="all"
license="Public-Domain"
subpackages="$pkgname-doc"
source="http://www.hashcash.org/source/hashcash-$pkgver.tgz"
-builddir="$srcdir/hashcash-$pkgver"
build() {
make
diff --git a/community/py3-deepdiff/APKBUILD b/community/py3-deepdiff/APKBUILD
index 29c81f7adb2..169d0e3d4c7 100644
--- a/community/py3-deepdiff/APKBUILD
+++ b/community/py3-deepdiff/APKBUILD
@@ -35,7 +35,7 @@ check() {
.testenv/bin/python3 -m installer .dist/*.whl
# needs newer pydantic version
.testenv/bin/python3 -m pytest -k 'not test_pydantic1 and not test_pydantic2'
-}
+}
package() {
python3 -m installer -d "$pkgdir" \
diff --git a/testing/pcsc-perl/APKBUILD b/testing/pcsc-perl/APKBUILD
index 536f2f1a593..b83c79b9ff6 100644
--- a/testing/pcsc-perl/APKBUILD
+++ b/testing/pcsc-perl/APKBUILD
@@ -11,17 +11,14 @@ depends="perl"
makedepends="pcsc-lite-dev perl-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/LudovicRousseau/pcsc-perl/archive/refs/tags/$pkgver.tar.gz"
-builddir="$srcdir/pcsc-perl-$pkgver"
options="!check" # no tests available
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}