aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2020-05-08 15:26:50 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-08 16:13:33 +0000
commit174183ffc582462ae8eaf468da032a6642e140c4 (patch)
tree1472388faf0c74e66dc1433b75213d1a7751d9bc
parent47d67ded2944e692b19ffafbd1b978d37c097a79 (diff)
testing/thunderbird: security upgrade to 68.8.0
-rw-r--r--testing/thunderbird/APKBUILD19
-rw-r--r--testing/thunderbird/fix-casts.patch198
2 files changed, 14 insertions, 203 deletions
diff --git a/testing/thunderbird/APKBUILD b/testing/thunderbird/APKBUILD
index c4c337adf3c..2938cd440f2 100644
--- a/testing/thunderbird/APKBUILD
+++ b/testing/thunderbird/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Joseph Benden <joe@benden.us>
pkgname=thunderbird
-pkgver=68.7.0
-pkgrel=1
+pkgver=68.8.0
+pkgrel=0
pkgdesc="Thunderbird email client"
url="https://www.thunderbird.net/"
arch="all !s390x !armhf !mips !mips64" # limited by rust and cargo. Fails on armhf due to bad assembly
@@ -86,12 +86,22 @@ source="https://ftp.mozilla.org/pub/thunderbird/releases/$pkgver/source/thunderb
fix-webrtc-glibcisms.patch
fix-sandbox-membarrier.patch
fd6847c9416f9eebde636e21d794d25d1be8791d.patch
- fix-casts.patch
thunderbird.desktop
"
# secfixes:
+# 68.8.0-r0:
+# - CVE-2020-12387
+# - CVE-2020-12392
+# - CVE-2020-12393
+# - CVE-2020-12395
+# - CVE-2020-12397
+# - CVE-2020-6831
# 68.7.0-r0:
+# - CVE-2020-6819
+# - CVE-2020-6820
+# - CVE-2020-6821
+# - CVE-2020-6822
# - CVE-2020-6825
# 68.6.0-r0:
# - CVE-2019-20503
@@ -293,7 +303,7 @@ END
"$pkgdir/usr/lib/$pkgname/thunderbird-bin"
}
-sha512sums="fae763030b7a54930291a10f298b7fa4ffc400849082f576556b9040d095f1007ae686daf1241dff8b73bac35c14acf21c156a18a3e16d62a7719c6cc34e4d1f thunderbird-68.7.0.source.tar.xz
+sha512sums="1af899913454e97ba3b08a090f775c0ce65ae6d8c1d31171017f09355a0bb126516d4770b4a4a0e774419497c404fa70dcfcafdf767c9caba0bf1d658c0d9350 thunderbird-68.8.0.source.tar.xz
0b3f1e4b9fdc868e4738b5c81fd6c6128ce8885b260affcb9a65ff9d164d7232626ce1291aaea70132b3e3124f5e13fef4d39326b8e7173e362a823722a85127 stab.h
3e57b2541f3889a1cf701860c8bf299f294cb077b0e8cfffda271cf02d1f59b25a697485d0df66e847e47f795b1ace54488a84a42851f2f8587717335537b44d disable-ccache-stats.patch
2f4f15974d52de4bb273b62a332d13620945d284bbc6fe6bd0a1f58ff7388443bc1d3bf9c82cc31a8527aad92b0cd3a1bc41d0af5e1800e0dcbd7033e58ffd71 fix-fortify-system-wrappers.patch
@@ -307,5 +317,4 @@ e0df4fc649012f023443ce9165da29d36459dbca5df64a31008b28d96264fba909858de36d0cf1b1
d35cacb9ede80e6bfbef0709823e536dddfb1c02d776275b0b7adb5969e9927d8c6117df96873569c3f3db0a18ee5db24f8086a9311a05077892be43a3dd8d79 fix-webrtc-glibcisms.patch
f85f2c19c3dafab915bcb40e580fc442fd9eab5916696849edf0b105c758dd807dfe23a6479935613c81496711eb377c73227c03eb8582204c3442a4d0e397a2 fix-sandbox-membarrier.patch
60845dcb034b2c4459c30f7d5f25c8176cf42df794e2cc0e86c3e2abb6541c24b962f3a16ca70a288d4d6f377b68d00b2904b22463108559612053d835d9bff1 fd6847c9416f9eebde636e21d794d25d1be8791d.patch
-f1c22c40909507a98cfb87942cbd78f2a7e657eb339f8784734c23b9b188d3b612ef3b0667f56dd10d90474742f7ef2468414a4b221497730c2ac4393707a628 fix-casts.patch
95a2b1deb4f6c90750fdd2bfe8ca0a7879a5b267965091705a6beb0a0a4b1ccad75d11df7b9885543ca4232ff704e975c6946f4c11804cb71c471e06f9576001 thunderbird.desktop"
diff --git a/testing/thunderbird/fix-casts.patch b/testing/thunderbird/fix-casts.patch
deleted file mode 100644
index 70b28800586..00000000000
--- a/testing/thunderbird/fix-casts.patch
+++ /dev/null
@@ -1,198 +0,0 @@
-Based on upstream commit - https://github.com/servo/servo/commit/98e4a53b7241d562d127e0f7005ffb38f21d1380.patch
-
----
-From 98e4a53b7241d562d127e0f7005ffb38f21d1380 Mon Sep 17 00:00:00 2001
-From: Simon Sapin <simon.sapin@exyr.org>
-Date: Fri, 16 Aug 2019 13:53:01 +0200
-Subject: [PATCH] Upgrade to rustc 1.39.0-nightly (f7af19c27 2019-08-15)
-
----
---- a/Cargo.lock
-+++ b/Cargo.lock
-@@ -235,7 +235,7 @@
- version = "0.49.4"
- source = "registry+https://github.com/rust-lang/crates.io-index"
- dependencies = [
-- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "cexpr 0.3.3 (registry+https://github.com/rust-lang/crates.io-index)",
- "cfg-if 0.1.6 (registry+https://github.com/rust-lang/crates.io-index)",
- "clang-sys 0.28.0 (registry+https://github.com/rust-lang/crates.io-index)",
-@@ -497,7 +497,7 @@
- dependencies = [
- "ansi_term 0.11.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "atty 0.2.11 (registry+https://github.com/rust-lang/crates.io-index)",
-- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "strsim 0.7.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "term_size 0.3.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "textwrap 0.9.0 (registry+https://github.com/rust-lang/crates.io-index)",
-@@ -510,7 +510,7 @@
- version = "0.0.3"
- source = "registry+https://github.com/rust-lang/crates.io-index"
- dependencies = [
-- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
- ]
-
- [[package]]
-@@ -563,7 +563,7 @@
- version = "0.17.1"
- source = "registry+https://github.com/rust-lang/crates.io-index"
- dependencies = [
-- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "core-foundation 0.6.3 (registry+https://github.com/rust-lang/crates.io-index)",
- "foreign-types 0.3.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "libc 0.2.51 (registry+https://github.com/rust-lang/crates.io-index)",
-@@ -801,7 +801,7 @@
- version = "0.5.4"
- source = "registry+https://github.com/rust-lang/crates.io-index"
- dependencies = [
-- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "cubeb-sys 0.5.4 (registry+https://github.com/rust-lang/crates.io-index)",
- ]
-
-@@ -1140,7 +1140,7 @@
- version = "0.3.3"
- source = "registry+https://github.com/rust-lang/crates.io-index"
- dependencies = [
-- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "fuchsia-zircon-sys 0.3.3 (registry+https://github.com/rust-lang/crates.io-index)",
- ]
-
-@@ -1630,7 +1630,7 @@
- version = "0.11.2"
- source = "registry+https://github.com/rust-lang/crates.io-index"
- dependencies = [
-- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "libc 0.2.51 (registry+https://github.com/rust-lang/crates.io-index)",
- "lmdb-rkv-sys 0.8.4 (registry+https://github.com/rust-lang/crates.io-index)",
- ]
-@@ -2004,7 +2004,7 @@
- name = "nsstring"
- version = "0.1.0"
- dependencies = [
-- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "encoding_rs 0.8.16 (registry+https://github.com/rust-lang/crates.io-index)",
- ]
-
-@@ -2228,7 +2228,7 @@
- version = "0.14.0"
- source = "registry+https://github.com/rust-lang/crates.io-index"
- dependencies = [
-- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "deflate 0.7.19 (registry+https://github.com/rust-lang/crates.io-index)",
- "inflate 0.4.5 (registry+https://github.com/rust-lang/crates.io-index)",
- "num-iter 0.1.37 (registry+https://github.com/rust-lang/crates.io-index)",
-@@ -2283,7 +2283,7 @@
- name = "pulse"
- version = "0.2.0"
- dependencies = [
-- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "pulse-ffi 0.1.0",
- ]
-
-@@ -2665,7 +2665,7 @@
- name = "selectors"
- version = "0.21.0"
- dependencies = [
-- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "cssparser 0.25.7 (registry+https://github.com/rust-lang/crates.io-index)",
- "derive_more 0.13.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "fxhash 0.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
-@@ -2881,7 +2881,7 @@
- "arrayvec 0.4.6 (registry+https://github.com/rust-lang/crates.io-index)",
- "atomic_refcell 0.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "bindgen 0.49.4 (registry+https://github.com/rust-lang/crates.io-index)",
-- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "byteorder 1.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
- "cssparser 0.25.7 (registry+https://github.com/rust-lang/crates.io-index)",
- "derive_more 0.13.0 (registry+https://github.com/rust-lang/crates.io-index)",
-@@ -2944,7 +2944,7 @@
- version = "0.0.1"
- dependencies = [
- "app_units 0.7.0 (registry+https://github.com/rust-lang/crates.io-index)",
-- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "cssparser 0.25.7 (registry+https://github.com/rust-lang/crates.io-index)",
- "euclid 0.19.5 (registry+https://github.com/rust-lang/crates.io-index)",
- "lazy_static 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)",
-@@ -3328,7 +3328,7 @@
- name = "u2fhid"
- version = "0.2.3"
- dependencies = [
-- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "boxfnonce 0.0.3 (registry+https://github.com/rust-lang/crates.io-index)",
- "core-foundation 0.6.3 (registry+https://github.com/rust-lang/crates.io-index)",
- "devd-rs 0.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
-@@ -3493,7 +3493,7 @@
- dependencies = [
- "base64 0.10.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "bincode 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)",
-- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "byteorder 1.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
- "cfg-if 0.1.6 (registry+https://github.com/rust-lang/crates.io-index)",
- "core-foundation 0.6.3 (registry+https://github.com/rust-lang/crates.io-index)",
-@@ -3533,7 +3533,7 @@
- dependencies = [
- "app_units 0.7.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "bincode 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)",
-- "bitflags 1.0.4 (registry+https://github.com/rust-lang/crates.io-index)",
-+ "bitflags 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
- "byteorder 1.3.1 (registry+https://github.com/rust-lang/crates.io-index)",
- "core-foundation 0.6.3 (registry+https://github.com/rust-lang/crates.io-index)",
- "core-graphics 0.17.1 (registry+https://github.com/rust-lang/crates.io-index)",
---- a/servo/components/style/stylesheets/viewport_rule.rs
-+++ b/servo/components/style/stylesheets/viewport_rule.rs
-@@ -291,15 +291,18 @@ impl<'a, 'b, 'i> DeclarationParser<'i> for ViewportRuleParser<'a, 'b> {
- ) -> Result<Vec<ViewportDescriptorDeclaration>, ParseError<'i>> {
- macro_rules! declaration {
- ($declaration:ident($parse:expr)) => {
-- declaration!($declaration(value: try!($parse(input)),
-- important: input.try(parse_important).is_ok()))
-+ declaration!($declaration {
-+ value: $parse(input)?,
-+ important: input.try(parse_important).is_ok(),
-+ })
- };
-- ($declaration:ident(value: $value:expr, important: $important:expr)) => {
-+ ($declaration:ident { value: $value:expr, important: $important:expr, }) => {
- ViewportDescriptorDeclaration::new(
- self.context.stylesheet_origin,
- ViewportDescriptor::$declaration($value),
-- $important)
-- }
-+ $important,
-+ )
-+ };
- }
-
- macro_rules! ok {
-@@ -311,8 +314,14 @@ impl<'a, 'b, 'i> DeclarationParser<'i> for ViewportRuleParser<'a, 'b> {
- let important = input.try(parse_important).is_ok();
-
- Ok(vec![
-- declaration!($min(value: shorthand.0, important: important)),
-- declaration!($max(value: shorthand.1, important: important)),
-+ declaration!($min {
-+ value: shorthand.0,
-+ important: important,
-+ }),
-+ declaration!($max {
-+ value: shorthand.1,
-+ important: important,
-+ }),
- ])
- }};
- }