aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWillow Barraco <contact@willowbarraco.fr>2023-03-26 07:34:25 +0200
committeralice <alice@ayaya.dev>2023-03-26 15:24:12 +0000
commit37b2062622d6f019908daf38cc035964a2ea2d5f (patch)
tree1caadd4e9d7364fec1cadff85208836f1e658a21
parent87d2c07e5ebb3e8f7d39ff183346b41e40c00b44 (diff)
community/tootle: remove
-rw-r--r--community/tootle/0001-Adhere-to-GLib.Object-naming-conventions-for-propert.patch69
-rw-r--r--community/tootle/0002-Use-reason_phrase-instead-of-get_phrase.patch55
-rw-r--r--community/tootle/0003-make-app-entries-private.patch24
-rw-r--r--community/tootle/APKBUILD44
-rw-r--r--community/tootle/fix-construct-prop.patch70
5 files changed, 0 insertions, 262 deletions
diff --git a/community/tootle/0001-Adhere-to-GLib.Object-naming-conventions-for-propert.patch b/community/tootle/0001-Adhere-to-GLib.Object-naming-conventions-for-propert.patch
deleted file mode 100644
index 64407cdf498..00000000000
--- a/community/tootle/0001-Adhere-to-GLib.Object-naming-conventions-for-propert.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From 4722a5c710261b95fbf455d9ec7b7967ca8e5c75 Mon Sep 17 00:00:00 2001
-From: Clayton Craft <clayton@craftyguy.net>
-Date: Tue, 26 Oct 2021 15:03:25 -0700
-Subject: [PATCH 1/2] Adhere to GLib.Object naming conventions for properties
-
-Vala now validates property names against GLib.Object conventions, this
-fixes a compilation error as a result of this enforcement:
-
-../src/API/Status.vala:27.5-27.23: error: Name `_url' is not valid for a GLib.Object property
- public string? _url { get; set; }
- ^^^^^^^^^^^^^^^^^^^
-
-Relevant Vala change:
-https://gitlab.gnome.org/GNOME/vala/-/commit/38d61fbff037687ea4772e6df85c7e22a74b335e
-
-fixes #337
-
-Signed-off-by: Clayton Craft <clayton@craftyguy.net>
----
- src/API/Attachment.vala | 6 +++---
- src/API/Status.vala | 8 ++++----
- 2 files changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/src/API/Attachment.vala b/src/API/Attachment.vala
-index 5c66e79..3749bd7 100644
---- a/src/API/Attachment.vala
-+++ b/src/API/Attachment.vala
-@@ -32,10 +32,10 @@ public class Tootle.API.Attachment : Entity {
- public string kind { get; set; }
- public string url { get; set; }
- public string? description { get; set; }
-- public string? _preview_url { get; set; }
-+ private string? t_preview_url { get; set; }
- public string? preview_url {
-- set { this._preview_url = value; }
-- get { return (this._preview_url == null || this._preview_url == "") ? url : _preview_url; }
-+ set { this.t_preview_url = value; }
-+ get { return (this.t_preview_url == null || this.t_preview_url == "") ? url : t_preview_url; }
- }
-
- public static Attachment from (Json.Node node) throws Error {
-diff --git a/src/API/Status.vala b/src/API/Status.vala
-index 4de9b9d..7ebb2e5 100644
---- a/src/API/Status.vala
-+++ b/src/API/Status.vala
-@@ -24,16 +24,16 @@ public class Tootle.API.Status : Entity, Widgetizable {
- public ArrayList<API.Mention>? mentions { get; set; default = null; }
- public ArrayList<API.Attachment>? media_attachments { get; set; default = null; }
-
-- public string? _url { get; set; }
-+ private string? t_url { get; set; }
- public string url {
- owned get { return this.get_modified_url (); }
-- set { this._url = value; }
-+ set { this.t_url = value; }
- }
- string get_modified_url () {
-- if (this._url == null) {
-+ if (this.t_url == null) {
- return this.uri.replace ("/activity", "");
- }
-- return this._url;
-+ return this.t_url;
- }
-
- public Status formal {
---
-2.33.1
-
diff --git a/community/tootle/0002-Use-reason_phrase-instead-of-get_phrase.patch b/community/tootle/0002-Use-reason_phrase-instead-of-get_phrase.patch
deleted file mode 100644
index 25ce630fd5d..00000000000
--- a/community/tootle/0002-Use-reason_phrase-instead-of-get_phrase.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From 09737d32285f0bad5555be61effab8d512809433 Mon Sep 17 00:00:00 2001
-From: Clayton Craft <clayton@craftyguy.net>
-Date: Tue, 26 Oct 2021 15:21:22 -0700
-Subject: [PATCH 2/2] Use reason_phrase instead of get_phrase
-
-Based on the patch here:
-https://github.com/bleakgrey/tootle/pull/336
-
-Rebased on 1.0 branch
----
- src/Services/Cache.vala | 2 +-
- src/Services/Network.vala | 7 +------
- 2 files changed, 2 insertions(+), 7 deletions(-)
-
-diff --git a/src/Services/Cache.vala b/src/Services/Cache.vala
-index 2251697..2ed314e 100644
---- a/src/Services/Cache.vala
-+++ b/src/Services/Cache.vala
-@@ -88,7 +88,7 @@ public class Tootle.Cache : GLib.Object {
- try {
- var code = msg.status_code;
- if (code != Soup.Status.OK) {
-- var error = network.describe_error (code);
-+ var error = msg.reason_phrase;
- throw new Oopsie.INSTANCE (@"Server returned $error");
- }
-
-diff --git a/src/Services/Network.vala b/src/Services/Network.vala
-index fa2839c..d0143b0 100644
---- a/src/Services/Network.vala
-+++ b/src/Services/Network.vala
-@@ -56,7 +56,7 @@ public class Tootle.Network : GLib.Object {
- else if (status == Soup.Status.CANCELLED)
- debug ("Message is cancelled. Ignoring callback invocation.");
- else
-- ecb ((int32) status, describe_error ((int32) status));
-+ ecb ((int32) status, msg.reason_phrase);
- });
- }
- catch (Error e) {
-@@ -65,11 +65,6 @@ public class Tootle.Network : GLib.Object {
- }
- }
-
-- public string describe_error (uint code) {
-- var reason = Soup.Status.get_phrase (code);
-- return @"$code: $reason";
-- }
--
- public void on_error (int32 code, string message) {
- warning (message);
- app.toast (message);
---
-2.33.1
-
diff --git a/community/tootle/0003-make-app-entries-private.patch b/community/tootle/0003-make-app-entries-private.patch
deleted file mode 100644
index 0da70c19801..00000000000
--- a/community/tootle/0003-make-app-entries-private.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Patch-Source: https://github.com/bleakgrey/tootle/pull/346
-From 11d94c05d4c4a2350801294f155230e899048ab5 Mon Sep 17 00:00:00 2001
-From: Bobby Rong <rjl931189261@126.com>
-Date: Sat, 19 Mar 2022 16:59:31 +0800
-Subject: [PATCH] Application: make app_entries private
-
-Fixes compilation with latest valac.
----
- src/Application.vala | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/Application.vala b/src/Application.vala
-index 57d0fd7..b48cb53 100644
---- a/src/Application.vala
-+++ b/src/Application.vala
-@@ -43,7 +43,7 @@ namespace Tootle {
- { null }
- };
-
-- public const GLib.ActionEntry[] app_entries = {
-+ private const GLib.ActionEntry[] app_entries = {
- { "about", about_activated },
- { "compose", compose_activated },
- { "back", back_activated },
diff --git a/community/tootle/APKBUILD b/community/tootle/APKBUILD
deleted file mode 100644
index 925e4b9d767..00000000000
--- a/community/tootle/APKBUILD
+++ /dev/null
@@ -1,44 +0,0 @@
-# Contributor: Clayton Craft <clayton@craftyguy.net>
-# Maintainer: Clayton Craft <clayton@craftyguy.net>
-pkgname=tootle
-pkgver=1.0
-pkgrel=2
-pkgdesc="Simple Mastodon client for Linux"
-url="https://github.com/bleakgrey/tootle"
-# riscv64 disabled due to missing rust in recursive dependency
-arch="all !s390x !riscv64" # no libhandy
-license="GPL-3.0-or-later"
-makedepends="
- glib-dev
- gtk+3.0-dev
- json-glib-dev
- libgee-dev
- libhandy1-dev
- libsoup-dev
- meson
- vala
- "
-subpackages="$pkgname-lang"
-source="$pkgname-$pkgver.tar.gz::https://github.com/bleakgrey/tootle/archive/$pkgver.tar.gz
- 0001-Adhere-to-GLib.Object-naming-conventions-for-propert.patch
- 0002-Use-reason_phrase-instead-of-get_phrase.patch
- 0003-make-app-entries-private.patch
- fix-construct-prop.patch
-"
-options="!check" # no tests
-
-build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
-}
-
-package() {
- DESTDIR="$pkgdir" meson install -C output
-}
-sha512sums="
-31eadfcc27cff26e8c84ecc56209e8bc9e0f616a9ab32a63208a89875597ecc668ac856a6044533b718c90f4acd286b7f07ca1386d6bb8d259a793e339a3f79d tootle-1.0.tar.gz
-f2c98f02e07bc8d065bee2c959f6339deb82f26ab69ad41de87f7792f1b794d00a817d8e3b02ea2170935eb983c07853c37f9d93eb6b5d2c78cc18f2057d35ca 0001-Adhere-to-GLib.Object-naming-conventions-for-propert.patch
-23de63b96506f01dd8619c7c13c8c58e2919fbfe20de531f48714ce017905c4762c3920ec3f7ebae8b42b393f2a751801d09ceb8352656895d55bbe76dc49917 0002-Use-reason_phrase-instead-of-get_phrase.patch
-a48e38b287f80bed78a23c7dbc10c9a30dffb0b5d72b70ab14b9e8727e3c6e7234999b5f142d1dbda9c67fff473eb91cdbfd106b03a58e4bb984904cfe59fac2 0003-make-app-entries-private.patch
-ac099d2e3abb4e47622336456415f272a7c5712b4a4d2fcd36ae3b9fd5629fd354d3d24428b41b406ed4ca51a1d348a118ac816af68144662ec9edc066959243 fix-construct-prop.patch
-"
diff --git a/community/tootle/fix-construct-prop.patch b/community/tootle/fix-construct-prop.patch
deleted file mode 100644
index 13c95186f58..00000000000
--- a/community/tootle/fix-construct-prop.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-Patch-Source: https://github.com/flathub/com.github.bleakgrey.tootle/pull/22
-diff --git a/src/API/NotificationType.vala b/src/API/NotificationType.vala
-index c3f4420..15ba2ae 100644
---- a/src/API/NotificationType.vala
-+++ b/src/API/NotificationType.vala
-@@ -5,7 +5,8 @@ public enum Tootle.API.NotificationType {
- FAVOURITE,
- FOLLOW,
- FOLLOW_REQUEST, // Internal
-- WATCHLIST; // Internal
-+ WATCHLIST, // Internal
-+ NONE; // Internal
-
- public string to_string () {
- switch (this) {
-diff --git a/src/Widgets/Notification.vala b/src/Widgets/Notification.vala
-index 3e2fe54..41ed71f 100644
---- a/src/Widgets/Notification.vala
-+++ b/src/Widgets/Notification.vala
-@@ -16,7 +16,7 @@ public class Tootle.Widgets.Notification : Widgets.Status {
- }
-
- protected override void on_kind_changed () {
-- if (kind == null)
-+ if (kind == API.NotificationType.NONE)
- return;
-
- header_icon.visible = header_label.visible = true;
-diff --git a/src/Widgets/Status.vala b/src/Widgets/Status.vala
-index ef51340..ce1c951 100644
---- a/src/Widgets/Status.vala
-+++ b/src/Widgets/Status.vala
-@@ -5,7 +5,7 @@ using Gdk;
- public class Tootle.Widgets.Status : ListBoxRow {
-
- public API.Status status { get; construct set; }
-- public API.NotificationType? kind { get; construct set; }
-+ public API.NotificationType kind { get; construct set; }
-
- public enum ThreadRole {
- NONE,
-@@ -113,7 +113,7 @@ public class Tootle.Widgets.Status : ListBoxRow {
- notify["kind"].connect (on_kind_changed);
- open.connect (on_open);
-
-- if (kind == null) {
-+ if (kind == API.NotificationType.NONE) {
- if (status.reblog != null)
- kind = API.NotificationType.REBLOG_REMOTE_USER;
- }
-@@ -164,7 +164,7 @@ public class Tootle.Widgets.Status : ListBoxRow {
- menu_button.clicked.connect (open_menu);
- }
-
-- public Status (owned API.Status status, API.NotificationType? kind = null) {
-+ public Status (owned API.Status status, API.NotificationType kind = API.NotificationType.NONE) {
- Object (
- status: status,
- kind: kind
-@@ -180,8 +180,8 @@ public class Tootle.Widgets.Status : ListBoxRow {
- }
-
- protected virtual void on_kind_changed () {
-- header_icon.visible = header_label.visible = (kind != null);
-- if (kind == null)
-+ header_icon.visible = header_label.visible = (kind != API.NotificationType.NONE);
-+ if (kind == API.NotificationType.NONE)
- return;
-
- header_icon.icon_name = kind.get_icon ();