aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2022-08-03 13:53:35 +0200
committerFrancesco Colista <fcolista@alpinelinux.org>2022-08-14 15:46:52 +0200
commit398540e3303f62ec7bac5007d41aacd0cd2b2c84 (patch)
treecb534dbf379e26e79f344ba2f8330b08c1ad613b
parent78c2992ab77924e2e191184fadb952af74c0ef0f (diff)
testing/kismet: upgrade to 2022-02-R1
-rw-r--r--testing/kismet/APKBUILD13
-rw-r--r--testing/kismet/sqlite3-longlong.patch21
2 files changed, 5 insertions, 29 deletions
diff --git a/testing/kismet/APKBUILD b/testing/kismet/APKBUILD
index f83006eefa1..75acb37a20d 100644
--- a/testing/kismet/APKBUILD
+++ b/testing/kismet/APKBUILD
@@ -1,16 +1,16 @@
# Contributor: George Hopkins <george-hopkins@null.net>
# Maintainer: George Hopkins <george-hopkins@null.net>
pkgname=kismet
-_pkgver=2020-12-R3
+_pkgver=2022-02-R1
pkgver=${_pkgver/-R/.}
pkgver=0.${pkgver/-/}
-pkgrel=4
+pkgrel=0
pkgdesc="Wireless network and device detector"
url="https://www.kismetwireless.net/"
arch="all"
license="GPL-2.0-only"
makedepends="linux-headers libnl3-dev libpcap-dev protobuf-dev protobuf-c-dev
- sqlite-dev zlib-dev"
+ sqlite zlib-dev"
subpackages="$pkgname-logtools
$pkgname-linux-bluetooth:linux_bluetooth
$pkgname-linux-wifi:linux_wifi
@@ -18,9 +18,7 @@ subpackages="$pkgname-logtools
$pkgname-nxp-kw41z:nxp_kw41z
"
options="!check" # no test-suite available
-source="$pkgname-$pkgver.tar.xz::https://www.kismetwireless.net/code/kismet-$_pkgver.tar.xz
- sqlite3-longlong.patch
- "
+source="$pkgname-$pkgver.tar.xz::https://www.kismetwireless.net/code/kismet-$_pkgver.tar.xz"
builddir="$srcdir/kismet-$_pkgver"
[ "$CARCH" = "riscv64" ] && options="$options textrels"
@@ -88,6 +86,5 @@ nxp_kw41z() {
}
sha512sums="
-6c4c95a9963977d5a383e34f662f814a803d0d36d7dbc35d3d0a42d3e67c20e8d46357df0ee544b8dd3c7f527bd43ef9c0d913577d4979f261764fc9761cd6d1 kismet-0.202012.3.tar.xz
-1f49cf45963f32b1eaec9b15e5cab53f46999362f87daf9b39f8f244fa3dd1ac602f0a22eb04682a3a22abcaf2b09fc59060ff12626844e77125b6a28e4350bd sqlite3-longlong.patch
+09292096614b9ca3569430ef196cd7cf6fbd2ab7212bdfc653cf5433bdc727ea48c63638220804799f9756a92108a85e8abf0f4e8e0383dbcbe0028bf91a6aee kismet-0.202202.1.tar.xz
"
diff --git a/testing/kismet/sqlite3-longlong.patch b/testing/kismet/sqlite3-longlong.patch
deleted file mode 100644
index 9fa7d83fd6c..00000000000
--- a/testing/kismet/sqlite3-longlong.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-On some systems time_t is defined as long long. In this case, the
-current release does not contain the appropriate getter to read
-values of this type from the database.
-
-https://github.com/kismetwireless/kismet/pull/334
-
-diff -ru a/sqlite3_cpp11.cc b/sqlite3_cpp11.cc
---- a/sqlite3_cpp11.cc 2020-12-06 21:24:46.000000000 +0100
-+++ b/sqlite3_cpp11.cc 2021-01-04 11:21:17.239367923 +0100
-@@ -412,6 +412,11 @@
- }
-
- template<>
-+ long long sqlite3_column_as(std::shared_ptr<sqlite3_stmt> stmt, unsigned int column) {
-+ return (long long) sqlite3_column_int64(stmt.get(), column);
-+ }
-+
-+ template<>
- unsigned long long sqlite3_column_as(std::shared_ptr<sqlite3_stmt> stmt, unsigned int column) {
- return (unsigned long long) sqlite3_column_int64(stmt.get(), column);
- }