aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-05-06 18:41:03 +0000
committerpsykose <alice@ayaya.dev>2023-05-06 20:41:03 +0200
commit3c6e5bf5596cca9c413939a78c4cc585c629a522 (patch)
tree6534bad29d122953f5d470320cded074772f55df
parent4cdcb97975047f19c0af06f127bf1fc3f9e14e74 (diff)
community/openvas-smb: rebuild, modernise
-rw-r--r--community/openvas-smb/001-cmakelist-fortify.patch13
-rw-r--r--community/openvas-smb/APKBUILD39
-rw-r--r--community/openvas-smb/implicit.patch39
3 files changed, 66 insertions, 25 deletions
diff --git a/community/openvas-smb/001-cmakelist-fortify.patch b/community/openvas-smb/001-cmakelist-fortify.patch
deleted file mode 100644
index cda525e3ef8..00000000000
--- a/community/openvas-smb/001-cmakelist-fortify.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 021b08f..cf21e05 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -150,7 +150,7 @@ pkg_check_modules (POPT REQUIRED popt)
- if(${GSSAPI_VERSION} VERSION_LESS "7.5.0")
- add_definitions(-DOLD_HEIMDAL)
- endif()
--set (CMAKE_C_FLAGS "-fPIC -O2 -D_FORTIFY_SOURCE=2 -fstack-protector ${CMAKE_C_FLAGS}")
-+set (CMAKE_C_FLAGS "-fPIC -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector ${CMAKE_C_FLAGS}")
- set (CMAKE_C_FLAGS "-Wno-unused-result -fno-strict-aliasing ${CMAKE_C_FLAGS}")
- set (LINKER_HARDENING_FLAGS "-Wl,-z,relro -Wl,-z,now")
-
diff --git a/community/openvas-smb/APKBUILD b/community/openvas-smb/APKBUILD
index 3cd9da456d1..33133b362be 100644
--- a/community/openvas-smb/APKBUILD
+++ b/community/openvas-smb/APKBUILD
@@ -2,33 +2,48 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=openvas-smb
pkgver=22.4.0
-pkgrel=0
+pkgrel=1
pkgdesc="SMB module for OpenVAS Scanner"
url="https://github.com/greenbone/openvas-smb"
arch="x86 x86_64"
license="GPL-2.0"
options="!check" #no check available
-makedepends="cmake mingw-w64-gcc mingw-w64-binutils mingw-w64-headers mingw-w64-crt
-gvm-libs-dev gnutls-dev popt-dev perl-dev
-glib-dev xmltoman doxygen graphviz heimdal-dev
-sqlite-dev libunistring-dev"
+makedepends="
+ cmake
+ doxygen
+ glib-dev
+ gnutls-dev
+ graphviz
+ gvm-libs-dev
+ heimdal-dev
+ libunistring-dev
+ mingw-w64-binutils
+ mingw-w64-crt
+ mingw-w64-gcc
+ mingw-w64-headers
+ perl-dev
+ popt-dev
+ samurai
+ sqlite-dev
+ xmltoman
+ "
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/greenbone/openvas-smb/archive/v$pkgver.tar.gz
fix-missing-includes-path.patch
comparison_fn_t.patch
disable-backtrace.patch
- 001-cmakelist-fortify.patch"
+ implicit.patch
+ "
build() {
- cmake \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_VERBOSE_MAKEFILE=ON .
- make
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
@@ -36,5 +51,5 @@ a31b440b8f87a17593e81318af2549167af0020dab4e52a5e45b269c1328af06ae971e0959bad245
126d522efcf7341680ba88e3545cee1da70b44bd2b9618d1f4324941ac38c9159eef8449a34acd71d9c0a2ccb8b98fa98a3bd1fc66608d99bd19365eceb6f3eb fix-missing-includes-path.patch
96b81bb378d0a70b1d31c19c646a95b96056ca3f85c02edc221bc17093b5403ba1fcdf9f3175e455aa32b7399e58a1c9cda525985c09c8b7dee8068bf3643a14 comparison_fn_t.patch
6a5f67177ca74ce051d190a81727b94938addf538c52831b5af3394f4d8d2ea990bcd58e3dc92570c7c4b0719deea49e2aa2fa549297c6e36ec4f8fa3f0a5270 disable-backtrace.patch
-56c150d8fcc46720d71a632e7f6ff7a1ad92d90c84361eb8ad81c4b4811ac9ff56f06654f70840895ac7bec4f852bafeff0599e29a4c5572d826403df1d2ca68 001-cmakelist-fortify.patch
+cdd3a45f33b651c31dcff40c1876f410a5fb63f579a2e91fb8824fa4f34524d1fd49478f074982c08a2009ef582f5ff9e23fc0d5b5aa9d905aa1048e0ed2a801 implicit.patch
"
diff --git a/community/openvas-smb/implicit.patch b/community/openvas-smb/implicit.patch
new file mode 100644
index 00000000000..7133bea952d
--- /dev/null
+++ b/community/openvas-smb/implicit.patch
@@ -0,0 +1,39 @@
+fix implicit function decls
+--
+diff --git a/samba/auth/credentials/credentials_krb5.c b/samba/auth/credentials/credentials_krb5.c
+index a4a0a9a..9b64977 100644
+--- a/samba/auth/credentials/credentials_krb5.c
++++ b/samba/auth/credentials/credentials_krb5.c
+@@ -28,6 +28,8 @@
+ #include "auth/credentials/credentials.h"
+ #include "auth/credentials/credentials_krb5.h"
+
++#include <gssapi/gssapi_krb5.h>
++
+ int cli_credentials_get_krb5_context(struct cli_credentials *cred,
+ struct smb_krb5_context **smb_krb5_context)
+ {
+diff --git a/wmi/wmireg.c b/wmi/wmireg.c
+index cb4cf6d..b13a587 100644
+--- a/wmi/wmireg.c
++++ b/wmi/wmireg.c
+@@ -36,6 +36,7 @@
+ #include "includes.h"
+ #include "lib/cmdline/popt_common.h"
+ #include "librpc/rpc/dcerpc.h"
++#include "librpc/rpc/dcerpc_table.h"
+ #include "librpc/gen_ndr/ndr_oxidresolver.h"
+ #include "librpc/gen_ndr/ndr_oxidresolver_c.h"
+ #include "librpc/gen_ndr/ndr_dcom.h"
+diff --git a/wmi/wmirsop.c b/wmi/wmirsop.c
+index 719bb9a..da642d3 100644
+--- a/wmi/wmirsop.c
++++ b/wmi/wmirsop.c
+@@ -36,6 +36,7 @@
+ #include "includes.h"
+ #include "lib/cmdline/popt_common.h"
+ #include "librpc/rpc/dcerpc.h"
++#include "librpc/rpc/dcerpc_table.h"
+ #include "librpc/gen_ndr/ndr_oxidresolver.h"
+ #include "librpc/gen_ndr/ndr_oxidresolver_c.h"
+ #include "librpc/gen_ndr/ndr_dcom.h"