aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-07 09:41:45 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-07 14:00:16 +0000
commit3d107d5ef037ca577da96e1c4c66def6214ba46a (patch)
treec4a44fe9ae03aac10923342a6a1e8ef3ac7d908d
parent41acd8e34d2a8eaa6e1867f826280dfe2cd915f3 (diff)
testing/galera: rebuild with python3
-rw-r--r--testing/galera/APKBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/testing/galera/APKBUILD b/testing/galera/APKBUILD
index 11216a8cf0b..10e585cfd2b 100644
--- a/testing/galera/APKBUILD
+++ b/testing/galera/APKBUILD
@@ -1,15 +1,15 @@
# Contributor: Jake Buchholz <tomalok@gmail.com>
# Maintainer: Jake Buchholz <tomalok@gmail.com>
-pkgname="galera"
-pkgver="26.4.3"
-pkgrel=0
+pkgname=galera
+pkgver=26.4.3
+pkgrel=1
_wsrepver=26
pkgdesc="Galera replication - Codership's implementation of the write set replication (wsrep) interface"
url="https://galeracluster.com"
arch="x86 x86_64" # doesn't work for the others
license="GPL-2.0-or-later"
depends="mariadb"
-makedepends="bash boost-dev check-dev cmake python scons openssl-dev"
+makedepends="bash boost-dev check-dev cmake python3 scons openssl-dev"
subpackages="$pkgname-arbitrator $pkgname-arbitrator-doc:arbitrator_doc"
source="
https://github.com/codership/galera/archive/release_$pkgver.tar.gz
@@ -21,6 +21,13 @@ source="
"
builddir="$srcdir/$pkgname-release_$pkgver"
+prepare() {
+ default_prepare
+
+ ln -s /usr/bin/python3 python
+ export PATH="$PATH:."
+}
+
build() {
rmdir wsrep/src
cp -a ../wsrep-API-release_v$_wsrepver wsrep/src