aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2020-03-07 18:32:49 +0100
committerJakub Jirutka <jakub@jirutka.cz>2020-03-07 18:34:47 +0100
commit5ef441eed397361115e8da52d178b2e1e8b89514 (patch)
treeb7a890caca78c64a472f3d21abe57aec15295bb0
parenta37eabf2264f3d9e12955ff0d2bf1f4cbb5b9152 (diff)
testing/sslh: allow to choose which binary to run by init script
-rw-r--r--testing/sslh/APKBUILD6
-rw-r--r--testing/sslh/sslh.confd8
-rw-r--r--testing/sslh/sslh.initd3
3 files changed, 13 insertions, 4 deletions
diff --git a/testing/sslh/APKBUILD b/testing/sslh/APKBUILD
index 49b2e6e4447..15ee5c39f5a 100644
--- a/testing/sslh/APKBUILD
+++ b/testing/sslh/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=sslh
pkgver=1.20
-pkgrel=2
+pkgrel=3
pkgdesc="Applicative Protocol Multiplexer (e.g. share SSH and HTTPS on the same port)"
url="http://www.rutschle.net/tech/sslh/README.html"
arch="all"
@@ -68,5 +68,5 @@ sha512sums="eccaddd5a4299206f195c2f7a78840b2f76f8a0cf10a715b5c72f959ed5d3259fc5e
b82d3c799f0cdf183fe0545e1d2b4f142070112d7ec3594afd709608c4893c300122aa32026dd7f8e782eb3981bf85fc02f878e2613ddfe014f39bbb94fb441e fix-make-install.patch
5773ee1d91e099726b614dbe385f2668699d25029fc300b664411c6082e95d3f27df11b9b1489bee3444c81bf941b8db13b4d382343788e47408c593c4531816 fail2ban.patch
c5e3d6714c5588731c749feaed24a8d551d1fbdc527348209465b9416efe4713ff9715eb10867fea13fd5cbdf2ab41d52019fb93d4e5ead29e8fda47581598aa config.patch
-95e114f2973d063679d628249030c4ea189f43821c28ac44973d71ed4c7be8de0417cfdff4318aec24fac6aec1b06735d5480f6f7aa193fae2ab5a8feffecd36 sslh.initd
-19a5556eb5232428c506986d0bf42e678b0b21f40d2efe3679bce10807d73b0df2172c198c7153125e4b66039c3af5c776f0e66997be5fffa5200c9d13d179e1 sslh.confd"
+20ad403c7e8bd37c849263886ff4307a478fbeaec74d52b7db864dea2e9bdafb2c501afd70fa2621385baf3536553a79cee006b4a629260921d2e08db7991696 sslh.initd
+7eaf99c6fb4505d0562c46ed2b3ae656b7c7c96223f2c7f11ab1bed72e9df0223a7ef02277ac50a633d165238efb8c54044eff38b488a7884b6671120d9e3f3e sslh.confd"
diff --git a/testing/sslh/sslh.confd b/testing/sslh/sslh.confd
index fca23f9c80e..5fec949a75e 100644
--- a/testing/sslh/sslh.confd
+++ b/testing/sslh/sslh.confd
@@ -1,5 +1,13 @@
# Configuration for /etc/init.d/sslh
+# The sslh binary to run; one of:
+#
+# fork Forks a new process for each incoming connection. It is well-tested
+# and very reliable, but incurs the overhead of many processes.
+# select Uses only one thread, which monitors all connections at once. It is
+# more recent and less tested, but has smaller overhead per connection.
+#mode="fork"
+
# Path of the configuration file.
#cfgfile="/etc/sslh.conf"
diff --git a/testing/sslh/sslh.initd b/testing/sslh/sslh.initd
index 46f9554c6c7..d5bab81390a 100644
--- a/testing/sslh/sslh.initd
+++ b/testing/sslh/sslh.initd
@@ -1,11 +1,12 @@
#!/sbin/openrc-run
: ${cfgfile:="/etc/sslh.conf"}
+: ${mode:="fork"}
: ${wait:=50} # milliseconds
description="Port multiplexer for SSH, HTTPS, OpenVPN etc."
-command="/usr/sbin/sslh"
+command="/usr/sbin/sslh-$mode"
command_args="-F$cfgfile -f ${command_args:-$DAEMON_OPTS}"
command_background="yes"
pidfile="/run/$RC_SVCNAME.pid"