aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-05-02 02:20:11 +0000
committerCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-05-02 02:46:43 +0000
commit630618bdac3ff9825451e0e0fc5be6bdf80116d8 (patch)
tree80283d8a60ebb844dc60de104a3753ba64dd221a
parent53e28e8d736cdbf49d7c2d87136ca6c8035f736c (diff)
community/py3-asttokens: deselect test_deep_recursion that fails on s390x
-rw-r--r--community/py3-asttokens/APKBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/community/py3-asttokens/APKBUILD b/community/py3-asttokens/APKBUILD
index ccf6b8c12a2..162e24de152 100644
--- a/community/py3-asttokens/APKBUILD
+++ b/community/py3-asttokens/APKBUILD
@@ -26,7 +26,16 @@ build() {
check() {
python3 -m venv --clear --without-pip --system-site-packages .testenv
.testenv/bin/python3 -m installer .dist/*.whl
- .testenv/bin/python3 -m pytest
+
+ case "$CARCH" in
+ s390x)
+ .testenv/bin/python3 -m pytest \
+ --deselect tests/test_mark_tokens.py::TestMarkTokens::test_deep_recursion
+ ;;
+ *)
+ .testenv/bin/python3 -m pytest
+ ;;
+ esac
}
package() {