aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoel Kuntze <noel.kuntze@thermi.consulting>2023-04-07 08:00:24 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2024-04-26 06:17:47 +0000
commit67d7766f2a4c6423a70109984882b6d7051cf2c4 (patch)
treea4497249c1125d48a7463f9bb4c872328ff81b7e
parent007db89f577e8221f42739dc69aa754b57e61f9c (diff)
testing/libvmime: upgrade to 0.9.2.175 commit fc69321d5304c73be685c890f3b30528aadcfeaf
-rw-r--r--testing/libvmime/APKBUILD34
-rw-r--r--testing/libvmime/fix-icu-70-1.patch38
2 files changed, 14 insertions, 58 deletions
diff --git a/testing/libvmime/APKBUILD b/testing/libvmime/APKBUILD
index 80ecd5cca6f..c642f599a75 100644
--- a/testing/libvmime/APKBUILD
+++ b/testing/libvmime/APKBUILD
@@ -1,12 +1,11 @@
# Maintainer: Noel Kuntze <noel.kuntze@thermi.consulting>
pkgname=libvmime
-pkgver=0.9.2_p4
-_pkgver=${pkgver//_p/k}
-pkgrel=10
+pkgver=0.9.2.175
+_commithash=fc69321d5304c73be685c890f3b30528aadcfeaf
+pkgrel=0
pkgdesc="Library for working with RFC 5322, MIME messages and IMAP/POP/SMTP"
-# ftbfs
-#arch="all"
url="https://www.vmime.org/"
+arch="all"
license="GPL-3.0-only"
# cmake config file isn't suitable for explicitely setting the TLS lib when it finds gnutls
makedepends="
@@ -23,35 +22,30 @@ makedepends="
"
checkdepends="icu-data-full"
subpackages="$pkgname-dbg $pkgname-dev"
-source="libvmime-$pkgver.tar.gz::https://github.com/Kopano-dev/vmime/archive/v$_pkgver.tar.gz
- fix-icu-70-1.patch
- gsasl-2.2.0.patch::https://github.com/kisli/vmime/commit/c750e899b8b3a76379167148468e164b7e52f6e2.patch
- "
+source="$pkgname-$pkgver-$_commithash.tar.gz::https://github.com/kisli/vmime/archive/fc69321d5304c73be685c890f3b30528aadcfeaf.tar.gz"
-builddir="$srcdir/vmime-$_pkgver"
+builddir="$srcdir/vmime-$_commithash"
-# can't build in other directory because cmake config is broken here.
-# library will not exist at package time.
build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
cmake -B . -G Ninja \
-DCMAKE_BUILD_TYPE=MinSizeRel \
- -DCMAKE_INSTALL_PREFIX=/usr/ \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
-DVMIME_BUILD_TESTS=ON \
- -DVMIME_TLS_SUPPORT_LIB=openssl
+ -DVMIME_TLS_SUPPORT_LIB=openssl \
+ $CMAKE_CROSSOPTS .
cmake --build .
}
-
check() {
LANG=C.UTF-8 build/bin/run-tests
}
package() {
DESTDIR="$pkgdir" cmake --install .
- mv "$pkgdir/usr/cmake" "$pkgdir/usr/lib/cmake"
}
-
sha512sums="
-90ebce51151944fe9cf09a8385b4ffe4db199c87e79579f66d70221f45a4bf4b048f3115077cff83536119af40ebe89eddacc301b54b7fb017438f44bd0f273c libvmime-0.9.2_p4.tar.gz
-65c0c1ec56a9a56167bb8b18e01feee4ea65fa958f5e2f233aa13d0472a803574d8b2751b2e6011edcd1db119f91c66e2401fd4916eecbb3af04dc2e527c125c fix-icu-70-1.patch
-6a07daff1b3830a913df722ed736465e8bbe022ee18b3ba1b704d58d3db16d8bbaeba5daa2e0705792b69aa2ced96b7d3c21a5e43a87b6585eaa318db069054e gsasl-2.2.0.patch
+a38dd4be95026738876c0328299f39e8b7fc17db14f0c89443bcda241894d49a22afb5e2bb9a13d087510e1db04a2c4d4691ff597db2a82fad4886b23b30c211 libvmime-0.9.2.175-fc69321d5304c73be685c890f3b30528aadcfeaf.tar.gz
"
diff --git a/testing/libvmime/fix-icu-70-1.patch b/testing/libvmime/fix-icu-70-1.patch
deleted file mode 100644
index 4b362e1c834..00000000000
--- a/testing/libvmime/fix-icu-70-1.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- a/src/vmime/charsetConverter_icu.cpp
-+++ b/src/vmime/charsetConverter_icu.cpp
-@@ -413,7 +413,7 @@
-
- ucnv_toUnicode(
- m_from, &uniTarget, uniTargetLimit,
-- &uniSource, uniSourceLimit, NULL, /* flush */ FALSE, &toErr
-+ &uniSource, uniSourceLimit, NULL, /* flush */ UBool(0), &toErr
- );
-
- if (U_FAILURE(toErr) && toErr != U_BUFFER_OVERFLOW_ERROR) {
-@@ -453,7 +453,7 @@
-
- ucnv_fromUnicode(
- m_to, &cpTarget, cpTargetLimit,
-- &cpSource, cpSourceLimit, NULL, /* flush */ FALSE, &fromErr
-+ &cpSource, cpSourceLimit, NULL, /* flush */ UBool(0), &fromErr
- );
-
- if (fromErr != U_BUFFER_OVERFLOW_ERROR && U_FAILURE(fromErr)) {
-@@ -509,7 +509,7 @@
-
- ucnv_toUnicode(
- m_from, &uniTarget, uniTargetLimit,
-- &uniSource, uniSourceLimit, NULL, /* flush */ TRUE, &toErr
-+ &uniSource, uniSourceLimit, NULL, /* flush */ UBool(1), &toErr
- );
-
- if (U_FAILURE(toErr) && toErr != U_BUFFER_OVERFLOW_ERROR) {
-@@ -540,7 +540,7 @@
-
- ucnv_fromUnicode(
- m_to, &cpTarget, cpTargetLimit,
-- &cpSource, cpSourceLimit, NULL, /* flush */ TRUE, &fromErr
-+ &cpSource, cpSourceLimit, NULL, /* flush */ UBool(1), &fromErr
- );
-
- if (fromErr != U_BUFFER_OVERFLOW_ERROR && U_FAILURE(fromErr)) {