aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-10-06 15:31:48 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-10-06 15:31:48 +0000
commit7ce5321eff4ef00bdb6409ca2af66f31353d2675 (patch)
treec41f8ec149ef501aae80188338c8271ea964680c
parent2a5757ada80401a5a4c5cd941121ae3e119703f3 (diff)
testing/py-tzlocal: upgrade to 1.4 and modernize
-rw-r--r--testing/py-tzlocal/APKBUILD28
1 files changed, 7 insertions, 21 deletions
diff --git a/testing/py-tzlocal/APKBUILD b/testing/py-tzlocal/APKBUILD
index efb8c06807d..9ea89d46914 100644
--- a/testing/py-tzlocal/APKBUILD
+++ b/testing/py-tzlocal/APKBUILD
@@ -1,40 +1,26 @@
# Maintainer: Peter Bui <pnutzh4x0r@gmail.com>
pkgname=py-tzlocal
_pkgname=tzlocal
-pkgver=1.2
+pkgver=1.4
pkgrel=0
pkgdesc="Python tzinfo object for the local timezone"
url="http://pytz.sourceforge.net/"
arch="noarch"
license="CC0 1.0"
depends="python2 py-tz"
-depends_dev=""
makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ cd "$builddir"
+ python2 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="2e36ceb1260bf1233ed2f018a1df536e tzlocal-1.2.tar.gz"
-sha256sums="438f122d684c951b22cb98aecc80fdb961b84e69542bf878c6b9a9419de09a8b tzlocal-1.2.tar.gz"
-sha512sums="eb4d1f73983579e109249884d2a343c441942fb0d4dc76aed693c4a05100b10a2337d72794fdb9c0cd28c3b73e11dbd030bdf6dc2f75e57c958655219973c814 tzlocal-1.2.tar.gz"
+sha512sums="e846f00cb0571da0c891ca8576d614ebfed622431201c713ef38a80fc990fa19298873bad74e5020648ec4b8307ce8362412e0e05d260121e9d70691814a321b tzlocal-1.4.tar.gz"