aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2024-05-04 17:08:38 +0200
committerMichał Polański <michal@polanski.me>2024-05-04 17:08:38 +0200
commit9893411e6ddc89c1bc977ad231c31fea8bde6ef8 (patch)
tree3edc4d8518d5c430d9efa76dfa0b981f52c77c8a
parent49da68a5714824e7755cf0187ee66523d0ea5c87 (diff)
community/black: increase max open file descriptors to 4096
Tests that start blackd server fail on arm builders with: OSError: [Errno 24] No file descriptors available The same issue appeared in a489f95448ea4b2f1779872ef590d2a36aa312b6
-rw-r--r--community/black/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/community/black/APKBUILD b/community/black/APKBUILD
index 92cbe2d5fc8..b6ceade4b1b 100644
--- a/community/black/APKBUILD
+++ b/community/black/APKBUILD
@@ -41,7 +41,7 @@ build() {
}
check() {
- ulimit -n 2048 # prevent running out of file descriptors
+ ulimit -n 4096 # prevent running out of file descriptors
./venv/bin/python3 -m pytest
}