aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjane400 <alpine@j4ne.de>2024-04-29 14:18:46 +0200
committerMichał Polański <michal@polanski.me>2024-05-04 13:53:59 +0000
commita8af19ee3dadbf13761e95cf6e1442aa1ea95378 (patch)
tree5ad3c5d260aebb2edf40215247e456959cec6df0
parent54685d918cbaa887dce1d120633cfb9baec1f80e (diff)
community/sway: bring -portalconf up to date with xdg
`DesktopNames` is now part of the spec, so remove the `X-` prefix, as gdm only queries `DesktopNames`. This actually sets XDG_CURRENT_DESKTOP with gdm now. Also add a warning for users of sway-portalsconf, that not all portals are provided by us. For things like the keyring or color-scheme more portal backends have to be specified. Also move the `sway-portals.conf` to `/usr/share/...` instead of `/etc`.
-rw-r--r--community/sway/APKBUILD8
-rw-r--r--community/sway/sway-portalsconf.pre-install15
l---------community/sway/sway-portalsconf.pre-upgrade1
-rw-r--r--community/sway/sway.desktop2
4 files changed, 21 insertions, 5 deletions
diff --git a/community/sway/APKBUILD b/community/sway/APKBUILD
index 7689a433158..de164007f1b 100644
--- a/community/sway/APKBUILD
+++ b/community/sway/APKBUILD
@@ -1,10 +1,9 @@
# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
-# Contributor:
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=sway
pkgver=1.9
-pkgrel=1
+pkgrel=2
pkgdesc="i3-compatible window manager for Wayland"
url="https://swaywm.org/"
license="MIT"
@@ -45,6 +44,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/swaywm/sway/archive/$pkgver.
sway.desktop
remove-aports-git-version.patch
"
+install="$pkgname-portalsconf.pre-install $pkgname-portalsconf.pre-upgrade"
options="setcap !check" # no test suite
# Remove when Alpine >= 3.21
@@ -76,7 +76,7 @@ portalsconf() {
install_if="$pkgname=$pkgver-r$pkgrel xdg-desktop-portal>=1.17.0"
install -Dm644 "$srcdir"/sway-portals.conf \
- -t "$subpkgdir"/etc/xdg-desktop-portal/
+ -t "$subpkgdir"/usr/share/xdg-desktop-portal/
}
wallpapers() {
@@ -104,6 +104,6 @@ swaynag() {
sha512sums="
7ec0a29078eb7e0fb1b6af97613c263adec78ddb03a63cb75fb5e44c7241ed144687fd094ee2eb70f4397832ca9bdffc88bc32dee7683bf0e515417c7a05d4c4 sway-1.9.tar.gz
c10862928d839a5a8a3a8c235ab9df58b0ffb111b7a0b11e9110b39169ac37de6e7eb1d945ec3611fb213ba159f0e47afd97085faa6ee8238e4d06fed0d74d70 sway-portals.conf
-c9bc08fbd9d059c037ad1e3b7ab5e91bcde27dce248cc558c1f126b01c85b1d0d4ed4bb10e3f27bc818a06e60a81f19478b95529d4eeb32036e2c6ea9f29db36 sway.desktop
+327f11cc053b39816da76a62199ef40f564acc1fe474b013fc1fd594c448ae3da805bfc475b7c68cce3a17b4a261c5a4bc7e9e91a471f90f5cf4e95bbd937e6c sway.desktop
3081f34ff88be38889ace94489ff4dc97a3d2d8402a6f2e83e968b991db478b7d3329d1685697898d8e43761e83be0d7c348a5fee45fe41dbb77521cda7b5a72 remove-aports-git-version.patch
"
diff --git a/community/sway/sway-portalsconf.pre-install b/community/sway/sway-portalsconf.pre-install
new file mode 100644
index 00000000000..241bf6b83c6
--- /dev/null
+++ b/community/sway/sway-portalsconf.pre-install
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+cat << __EOF__
+*
+* The sway-portals.conf from the package \`sway-portalsconf\` doesn't specify multiple
+* important portal backends, as this is left for the user to configure. Mainly
+* org.freedesktop.Settings (used for e.g the color scheme) and org.freedesktop.Secret.
+*
+* See also:
+* - \`man 5 portals.conf\`
+* - https://flatpak.github.io/xdg-desktop-portal/docs/backends.html
+*
+__EOF__
+
+exit 0
diff --git a/community/sway/sway-portalsconf.pre-upgrade b/community/sway/sway-portalsconf.pre-upgrade
new file mode 120000
index 00000000000..61ee7b5fc30
--- /dev/null
+++ b/community/sway/sway-portalsconf.pre-upgrade
@@ -0,0 +1 @@
+sway-portalsconf.pre-install \ No newline at end of file
diff --git a/community/sway/sway.desktop b/community/sway/sway.desktop
index 8800aecd8b3..26bc4027850 100644
--- a/community/sway/sway.desktop
+++ b/community/sway/sway.desktop
@@ -7,5 +7,5 @@ Exec=dbus-run-session /usr/bin/sway
TryExec=/usr/bin/sway
Icon=
Type=Application
-X-DesktopNames=Sway
+DesktopNames=Sway
Keywords=launch;Sway;desktop;session;