aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2023-12-19 22:39:10 +0100
committeromni <omni+alpine@hack.org>2023-12-19 23:44:25 +0000
commitbe0a03b668a3645795007e762bc0bdcae7eb7a9e (patch)
treeeb79cb184b627940aa873b0f23ef7ec71dc9489a
parentb3b11fab054468f565777d32493039fe901fcef3 (diff)
community/gjs: re-enable on riscv64
linking with bfd instead of lld
-rw-r--r--community/gjs/APKBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/community/gjs/APKBUILD b/community/gjs/APKBUILD
index 887b6d8b6d7..7cb31e1629a 100644
--- a/community/gjs/APKBUILD
+++ b/community/gjs/APKBUILD
@@ -17,7 +17,6 @@ makedepends="
gobject-introspection-dev
gtk+3.0-dev
libffi>=3.3
- lld
meson
mozjs115-dev
"
@@ -27,6 +26,15 @@ source="https://download.gnome.org/sources/gjs/${pkgver%.*}/gjs-$pkgver.tar.xz
encoding.patch
"
+case "$CARCH" in
+riscv64)
+ # lld broken on riscv64
+ ;;
+*)
+ makedepends="$makedepends lld"
+ ;;
+esac
+
build() {
case "$CARCH" in
aarch64|arm*|riscv64)
@@ -42,6 +50,7 @@ build() {
;;
*)
local lto=true
+ export LDFLAGS="$LDFLAGS -fuse-ld=lld"
;;
esac
@@ -49,7 +58,6 @@ build() {
CXX=clang++ \
CFLAGS="$CFLAGS -O2" \
CXXFLAGS="$CXXFLAGS -O2" \
- LDFLAGS="$LDFLAGS -fuse-ld=lld" \
abuild-meson \
--buildtype=release \
-Db_lto=$lto \