aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-09 19:13:58 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-09 19:13:58 -0300
commitf4e6e30c630e8540068ce3c2032dbb34c00ce5db (patch)
tree1990b0ab10b1d72ce3a74e0bfd5ae5ae8eb272cd
parent69254fa46edc6d4ceb8419daf903724d0b863875 (diff)
testing/polyml: try fixing build in x86 with libffi>=3.3-r0
-rw-r--r--testing/polyml/APKBUILD2
-rw-r--r--testing/polyml/fix-build-libffi-3.3.patch25
2 files changed, 12 insertions, 15 deletions
diff --git a/testing/polyml/APKBUILD b/testing/polyml/APKBUILD
index b2349d62b80..52022682009 100644
--- a/testing/polyml/APKBUILD
+++ b/testing/polyml/APKBUILD
@@ -43,4 +43,4 @@ package() {
}
sha512sums="50baed79b50b14bd87acc637de93fd6d0f05e61fe0f03682a12a1d2c5f382313488d48f84b49ad915b01acc5a3a5769fb05fcaa7b24499c56402ddd3ba393930 polyml-5.8.tar.gz
-40dbacbf573d63ed8eb75365c2bef2d54887d819321379b08b8dac9f526d2d3323bf2627964e65af273160d16129bf16e6dc389d47f653022882d28b7f98a0fe fix-build-libffi-3.3.patch"
+cbd4d2ac5ec9bcbd5e68a5d73370f9ae539f185a1f62bfee54f43c062c77bece16f8f60758c72eb25a51be569bd800af230fd45a5ba5640abf79f7814b12d36e fix-build-libffi-3.3.patch"
diff --git a/testing/polyml/fix-build-libffi-3.3.patch b/testing/polyml/fix-build-libffi-3.3.patch
index 56b957bcf51..c0d1a990ef4 100644
--- a/testing/polyml/fix-build-libffi-3.3.patch
+++ b/testing/polyml/fix-build-libffi-3.3.patch
@@ -1,19 +1,16 @@
---- a/libpolyml/polyffi.cpp 2019-04-05 23:10:23.509729312 +0200
-+++ b/libpolyml/polyffi.cpp 2019-04-05 23:10:38.895485058 +0200
-@@ -89,7 +89,6 @@
- // Unfortunately the ABI entries are enums rather than #defines so we
- // can't test individual entries.
- #ifdef X86_WIN32
-- {"sysv", FFI_SYSV},
- {"stdcall", FFI_STDCALL},
- {"thiscall", FFI_THISCALL},
- {"fastcall", FFI_FASTCALL},
-@@ -97,7 +96,6 @@
+diff --git a/libpolyml/polyffi.cpp b/libpolyml/polyffi.cpp
+index 5424dd8..a11987f 100644
+--- a/libpolyml/polyffi.cpp
++++ b/libpolyml/polyffi.cpp
+@@ -110,9 +110,10 @@ static struct _abiTable { const char *abiName; ffi_abi abiCode; } abiTable[] =
+ {"ms_cdecl", FFI_MS_CDECL},
#elif defined(X86_WIN64)
{"win64", FFI_WIN64},
++#elif defined(X86_64)
++ {"unix64", FFI_UNIX64},
#elif defined(X86_ANY)
-- {"sysv", FFI_SYSV},
- {"unix64", FFI_UNIX64},
+ {"sysv", FFI_SYSV},
+- {"unix64", FFI_UNIX64},
#endif
{ "default", FFI_DEFAULT_ABI}
-
+ };