aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoromni <omni+alpine@hack.org>2024-05-05 11:14:00 +0000
committeromni <omni+alpine@hack.org>2024-05-05 17:17:06 +0000
commitfbe83aea4d37173b3b9917e3724f4ac5c685368d (patch)
treeb15154f232874b456657c82b4d47782553335e9c
parent2f8d9dc6a8fb5eca4724322676a08d8ec4a64ef1 (diff)
community/py3-execnet: upgrade to 2.1.1 & switch to gpep517
update pkgdesc and url
-rw-r--r--community/py3-execnet/APKBUILD35
1 files changed, 15 insertions, 20 deletions
diff --git a/community/py3-execnet/APKBUILD b/community/py3-execnet/APKBUILD
index 6f630b1d661..d5205877de1 100644
--- a/community/py3-execnet/APKBUILD
+++ b/community/py3-execnet/APKBUILD
@@ -1,38 +1,33 @@
# Contributor: Dmitry Romanenko <dmitry@romanenko.in>
# Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
pkgname=py3-execnet
-_pkgname=execnet
-pkgver=1.9.0
-pkgrel=3
-pkgdesc="execnet: rapid multi-Python deployment"
-url="https://github.com/pytest-dev/execnet"
+pkgver=2.1.1
+pkgrel=0
+pkgdesc="distributed Python deployment and communication"
+url="https://execnet.readthedocs.io"
arch="noarch"
license="MIT"
-depends="py3-apipkg"
-# tests for py-gevent are broken, jython is missing in repo, eventlet is part
-# of testing
-checkdepends="py3-pytest py3-py"
-makedepends="py3-setuptools py3-setuptools_scm"
+makedepends="py3-gpep517 py3-hatch-vcs py3-setuptools py3-wheel"
+checkdepends="py3-pytest"
subpackages="$pkgname-pyc"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
-
-replaces="py-execnet" # Backwards compatibility
-provides="py-execnet=$pkgver-r$pkgrel" # Backwards compatibility
+source="https://files.pythonhosted.org/packages/source/e/execnet/execnet-$pkgver.tar.gz"
+builddir="$srcdir"/execnet-$pkgver
build() {
- python3 setup.py build
+ gpep517 build-wheel --wheel-dir .dist --output-fd 3 3>&1 >&2
+
}
check() {
- mv $builddir/doc/example/conftest.py $builddir
- python3 -m pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --skip-build --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
sha512sums="
-d425e7b6f3708efecb5dfa2c36a837cb55f2c32cf2ec0c1dc11cd1ca6ea614d119d04908b84dd5a3593c87db35e71fee202f843665c853ac3538479f60c83d60 execnet-1.9.0.tar.gz
+486f906ad653d16cce7337d9085c36070fe3dd721a3723ca62ceb25862c3ff837120062df028d5aadec17f854c0d46204537e9d75d22079a677f08c50dd48d21 execnet-2.1.1.tar.gz
"