aboutsummaryrefslogtreecommitdiffstats
path: root/community/ansible-core/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ansible-core/APKBUILD')
-rw-r--r--community/ansible-core/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/community/ansible-core/APKBUILD b/community/ansible-core/APKBUILD
index 1d3c60b8caa..fded7a577ce 100644
--- a/community/ansible-core/APKBUILD
+++ b/community/ansible-core/APKBUILD
@@ -1,8 +1,10 @@
# Contributor: Sean McAvoy <seanmcavoy@gmail.com>
+# Contributor: Thomas Böhler <witcher@wiredspace.de>
# Maintainer: Sean McAvoy <seanmcavoy@gmail.com>
pkgname=ansible-core
-pkgver=2.16.5
-pkgrel=1
+_pkgname=${pkgname/-/_}
+pkgver=2.17.0
+pkgrel=0
pkgdesc="core components of ansible: A configuration-management, deployment, task-execution, and multinode orchestration framework"
url="https://ansible.com"
options="!check" # for now
@@ -19,8 +21,9 @@ depends="
"
makedepends="py3-setuptools py3-docutils"
subpackages="$pkgname-doc $pkgname-pyc"
-source="https://pypi.python.org/packages/source/a/ansible-core/ansible-core-$pkgver.tar.gz
- "
+# tarball is named "ansible_core" instead of "ansible-core" since 2.16.6
+source="$pkgname-$pkgver.tar.gz::https://pypi.python.org/packages/source/a/ansible-core/ansible_core-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
replaces="ansible-base"
@@ -36,5 +39,5 @@ package() {
install -Dm644 man/ansible*1 -t "$pkgdir"/usr/share/man/man1/
}
sha512sums="
-dbe5d68fbc3a0ef611791d6995297bca5bba6aed1f4871964136ea81810458646bc78c2146739f887de3c2e3017cf4e6d4d09652e41c2ca046c4bc88eca6c5d8 ansible-core-2.16.5.tar.gz
+32206982158c060254c3b2d470e96c67b3cd91dae83f9888ac236395f540fa3b15bafa7a56e355e3bedbcc9726d78a8fc78a84468805acc8c06c6c3af7abf9aa ansible-core-2.17.0.tar.gz
"