aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-aiohttp1/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-aiohttp1/APKBUILD')
-rw-r--r--community/py3-aiohttp1/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/py3-aiohttp1/APKBUILD b/community/py3-aiohttp1/APKBUILD
new file mode 100644
index 00000000000..b761555763d
--- /dev/null
+++ b/community/py3-aiohttp1/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-aiohttp1
+_pkgname=aiohttp
+pkgver=1.3.5
+pkgrel=0
+pkgdesc="HTTP client/server for asyncio - 1.x version"
+url="http://pypi.python.org/pypi/aiohttp"
+arch="all"
+license="ASL 2.0"
+depends="python3 py3-async-timeout py3-chardet py3-multidict py3-yarl !py3-aiohttp"
+makedepends="python3-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/aio-libs/aiohttp/archive/$pkgver.tar.gz
+ dropped-requirements.patch"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --root="$pkgdir" --optimize=1
+}
+
+sha512sums="5315d8c77d6886486274fb8f2e3f10cb8f97050b097560e5b1cfd51b4d094dc45281cad894ea51079c6b7054f396d46b89f4c471835d1b058dcc90faaf01eaa4 py3-aiohttp1-1.3.5.tar.gz
+29e8172c2038b2900e82de0eb5b47f3265b144e5ec470a1868d3453a1be2e5295c5363bac258120f49ed785d2c82ae14f185292a28847a40b44d7b071b8dd083 dropped-requirements.patch"