aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-jmespath/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-jmespath/APKBUILD')
-rw-r--r--community/py3-jmespath/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/community/py3-jmespath/APKBUILD b/community/py3-jmespath/APKBUILD
index 22316e6842d..8a0fe000822 100644
--- a/community/py3-jmespath/APKBUILD
+++ b/community/py3-jmespath/APKBUILD
@@ -2,13 +2,13 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
pkgname=py3-jmespath
pkgver=1.0.1
-pkgrel=2
+pkgrel=3
pkgdesc="JMESPath is a query language for JSON"
url="https://jmespath.org"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
checkdepends="py3-pytest"
subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/j/jmespath/jmespath-$pkgver.tar.gz"
@@ -18,15 +18,18 @@ replaces=py-jmespath # Backwards compatibility
provides=py-jmespath=$pkgver-r$pkgrel # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel --wheel-dir .dist --output-fd 3 3>&1 >&2
+
}
check() {
- pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --skip-build --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
sha512sums="