aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-webauthn/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-webauthn/APKBUILD')
-rw-r--r--community/py3-webauthn/APKBUILD21
1 files changed, 16 insertions, 5 deletions
diff --git a/community/py3-webauthn/APKBUILD b/community/py3-webauthn/APKBUILD
index b4eefcbdaff..a283553467f 100644
--- a/community/py3-webauthn/APKBUILD
+++ b/community/py3-webauthn/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-webauthn
_pyname=webauthn
pkgver=2.1.0
-pkgrel=1
+pkgrel=2
arch="noarch"
pkgdesc="A Python3 implementation of the WebAuthn API focused on making it easy to leverage the power of WebAuthn."
url="https://pypi.python.org/project/webauthn"
@@ -13,9 +13,14 @@ makedepends="
py3-gpep517
py3-wheel
"
-options="!check" # No testsuite
-source="$pkgname-$pkgver.tar.gz::https://pypi.io/packages/source/w/webauthn/webauthn-$pkgver.tar.gz"
-builddir="$srcdir"/$_pyname-$pkgver
+checkdepends="
+ py3-pytest
+ py3-cbor2
+ py3-openssl
+ py3-asn1crypto
+"
+source="$pkgname-$pkgver-gh.tar.gz::https://github.com/duo-labs/py_webauthn/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir"/py_webauthn-$pkgver
subpackages="$pkgname-pyc"
build() {
@@ -24,10 +29,16 @@ build() {
--output-fd 3 3>&1 >&2
}
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -v
+}
+
package() {
python3 -m installer -d "$pkgdir" \
.dist/*.whl
}
sha512sums="
-2fe9b2222ead7cd75a327f6d793c2011a31f53d67cb3a7a0fe3a9dc89f9ccb9ef25a5d015b19ca4205aa16a967eb004b6fbb775b92e38bf81b7160b64faf07c0 py3-webauthn-2.1.0.tar.gz
+1191d9d45e51685c4179c6abbfcfc811986a18f42cb68b5dcc396f3a5a573884a62bc7bb2349df678e505ee1404b13ae1c4547022539e1c20d835134d114aba8 py3-webauthn-2.1.0-gh.tar.gz
"