aboutsummaryrefslogtreecommitdiffstats
path: root/community/watchexec/system-dbus.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/watchexec/system-dbus.patch')
-rw-r--r--community/watchexec/system-dbus.patch717
1 files changed, 241 insertions, 476 deletions
diff --git a/community/watchexec/system-dbus.patch b/community/watchexec/system-dbus.patch
index 74f5be94e13..d5bacdbf640 100644
--- a/community/watchexec/system-dbus.patch
+++ b/community/watchexec/system-dbus.patch
@@ -1,91 +1,71 @@
--- a/Cargo.lock
+++ b/Cargo.lock
-@@ -121,140 +121,15 @@
- ]
+@@ -143,123 +143,15 @@
+ checksum = "96d30a06541fbafbc7f82ed10c06164cfbd2c401138f6addd8404629c4b16711"
[[package]]
-name = "async-broadcast"
--version = "0.5.1"
+-version = "0.7.0"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "7c48ccdbf6ca6b121e0f586cbc0e73ae440e56c67c30fa0873b4e110d9c26d2b"
+-checksum = "258b52a1aa741b9f09783b2d86cf0aeeb617bbf847f6933340a39644227acbdb"
-dependencies = [
-- "event-listener 2.5.3",
+- "event-listener 5.3.0",
+- "event-listener-strategy 0.5.1",
- "futures-core",
+- "pin-project-lite",
-]
-
-[[package]]
-name = "async-channel"
--version = "2.1.1"
+-version = "2.2.1"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "1ca33f4bc4ed1babef42cad36cc1f51fa88be00420404e5b1e80ab1b18f7678c"
+-checksum = "136d4d23bcc79e27423727b36823d86233aad06dfea531837b038394d11e9928"
-dependencies = [
- "concurrent-queue",
-- "event-listener 4.0.2",
-- "event-listener-strategy",
+- "event-listener 5.3.0",
+- "event-listener-strategy 0.5.1",
- "futures-core",
- "pin-project-lite",
-]
-
-[[package]]
-name = "async-executor"
--version = "1.8.0"
+-version = "1.11.0"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "17ae5ebefcc48e7452b4987947920dac9450be1110cadf34d1b8c116bdbaf97c"
+-checksum = "b10202063978b3351199d68f8b22c4e47e4b1b822f8d43fd862d5ea8c006b29a"
-dependencies = [
-- "async-lock 3.2.0",
- "async-task",
- "concurrent-queue",
-- "fastrand 2.0.1",
-- "futures-lite 2.1.0",
+- "fastrand",
+- "futures-lite",
- "slab",
-]
-
-[[package]]
-name = "async-fs"
--version = "1.6.0"
+-version = "2.1.1"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "279cf904654eeebfa37ac9bb1598880884924aab82e290aa65c9e77a0e142e06"
+-checksum = "bc19683171f287921f2405677dd2ed2549c3b3bda697a563ebc3a121ace2aba1"
-dependencies = [
-- "async-lock 2.8.0",
-- "autocfg",
+- "async-lock 3.3.0",
- "blocking",
-- "futures-lite 1.13.0",
+- "futures-lite",
-]
-
-[[package]]
-name = "async-io"
--version = "1.13.0"
+-version = "2.3.2"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "0fc5b45d93ef0529756f812ca52e44c221b35341892d3dcc34132ac02f3dd2af"
+-checksum = "dcccb0f599cfa2f8ace422d3555572f47424da5648a4382a9dd0310ff8210884"
-dependencies = [
-- "async-lock 2.8.0",
-- "autocfg",
-- "cfg-if",
-- "concurrent-queue",
-- "futures-lite 1.13.0",
-- "log",
-- "parking",
-- "polling 2.8.0",
-- "rustix 0.37.27",
-- "slab",
-- "socket2 0.4.10",
-- "waker-fn",
--]
--
--[[package]]
--name = "async-io"
--version = "2.2.2"
--source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "6afaa937395a620e33dc6a742c593c01aced20aa376ffb0f628121198578ccc7"
--dependencies = [
-- "async-lock 3.2.0",
+- "async-lock 3.3.0",
- "cfg-if",
- "concurrent-queue",
- "futures-io",
-- "futures-lite 2.1.0",
+- "futures-lite",
- "parking",
-- "polling 3.3.1",
-- "rustix 0.38.28",
+- "polling",
+- "rustix",
- "slab",
- "tracing",
- "windows-sys 0.52.0",
@@ -102,12 +82,12 @@
-
-[[package]]
-name = "async-lock"
--version = "3.2.0"
+-version = "3.3.0"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "7125e42787d53db9dd54261812ef17e937c95a51e4d291373b670342fa44310c"
+-checksum = "d034b430882f8381900d3fe6f0aaa3ad94f2cb4ac519b429692a1bc2dda4ae7b"
-dependencies = [
-- "event-listener 4.0.2",
-- "event-listener-strategy",
+- "event-listener 4.0.3",
+- "event-listener-strategy 0.4.0",
- "pin-project-lite",
-]
-
@@ -117,32 +97,35 @@
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "acde96f444d31031f760c5c43dc786b97d3e1cb2ee49dd06898383fe9a999758"
dependencies = [
-- "event-listener 4.0.2",
+- "event-listener 4.0.3",
+ "event-listener",
]
[[package]]
-name = "async-process"
--version = "1.8.1"
+-version = "2.2.1"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "ea6438ba0a08d81529c69b36700fa2f95837bfe3e776ab39cde9c14d9149da88"
+-checksum = "cad07b3443bfa10dcddf86a452ec48949e8e7fedf7392d82de3969fda99e90ed"
-dependencies = [
-- "async-io 1.13.0",
-- "async-lock 2.8.0",
+- "async-channel",
+- "async-io",
+- "async-lock 3.3.0",
- "async-signal",
+- "async-task",
- "blocking",
- "cfg-if",
-- "event-listener 3.1.0",
-- "futures-lite 1.13.0",
-- "rustix 0.38.28",
-- "windows-sys 0.48.0",
+- "event-listener 5.3.0",
+- "futures-lite",
+- "rustix",
+- "tracing",
+- "windows-sys 0.52.0",
-]
-
-[[package]]
name = "async-recursion"
- version = "1.0.5"
+ version = "1.1.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -266,24 +141,6 @@
+@@ -271,24 +163,6 @@
]
[[package]]
@@ -151,13 +134,13 @@
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "9e47d90f65a225c4527103a8d747001fc56e375203592b25ad103e1ca13124c5"
-dependencies = [
-- "async-io 2.2.2",
+- "async-io",
- "async-lock 2.8.0",
- "atomic-waker",
- "cfg-if",
- "futures-core",
- "futures-io",
-- "rustix 0.38.28",
+- "rustix",
- "signal-hook-registry",
- "slab",
- "windows-sys 0.48.0",
@@ -167,7 +150,7 @@
name = "async-stream"
version = "0.3.5"
source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -306,12 +163,6 @@
+@@ -311,12 +185,6 @@
]
[[package]]
@@ -178,9 +161,9 @@
-
-[[package]]
name = "async-trait"
- version = "0.1.77"
+ version = "0.1.80"
source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -329,12 +180,6 @@
+@@ -334,12 +202,6 @@
checksum = "a8ab6b55fe97976e46f91ddbed8d147d966475dc29b2032757ba47e02376fbc3"
[[package]]
@@ -191,9 +174,9 @@
-
-[[package]]
name = "autocfg"
- version = "1.1.0"
+ version = "1.2.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -434,31 +279,6 @@
+@@ -462,31 +324,6 @@
checksum = "0d8c1fef690941d3e7788d328517591fecc684c084084702d6ff1641e993699a"
[[package]]
@@ -212,64 +195,37 @@
-checksum = "6a37913e8dc4ddcc604f0c6d3bf2887c995153af3611de9e23c352b44c1b9118"
-dependencies = [
- "async-channel",
-- "async-lock 3.2.0",
+- "async-lock 3.3.0",
- "async-task",
-- "fastrand 2.0.1",
+- "fastrand",
- "futures-io",
-- "futures-lite 2.1.0",
+- "futures-lite",
- "piper",
- "tracing",
-]
-
-[[package]]
name = "bosion"
- version = "1.0.2"
+ version = "1.0.3"
dependencies = [
-@@ -519,7 +339,7 @@
- "c-scape",
- "errno",
- "libc",
-- "rustix 0.38.28",
-+ "rustix",
- "tz-rs",
- ]
-
-@@ -533,7 +353,7 @@
- "errno",
- "libc",
- "libm",
-- "memoffset 0.9.0",
-+ "memoffset",
- "num-complex",
- "origin",
- "posix-regex",
-@@ -542,7 +362,7 @@
- "rand_core",
- "rand_pcg",
- "realpath-ext",
-- "rustix 0.38.28",
-+ "rustix",
- "rustix-dlmalloc",
- "rustix-futex-sync",
- "rustix-openpty",
-@@ -750,15 +570,6 @@
+@@ -775,15 +612,6 @@
checksum = "06ea2b9bc92be3c2baa9334a323ebca2d6f074ff852cd1d7b11064035cd3868f"
[[package]]
-name = "cpufeatures"
--version = "0.2.11"
+-version = "0.2.12"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "ce420fe07aecd3e67c5f910618fe65e94158f6dcc0adf44e00d69ce2bdfe0fd0"
+-checksum = "53fe5e26ff1b7aef8bca9c6080520cfb8d9333c7568e1829cef191a9723e5504"
-dependencies = [
- "libc",
-]
-
-[[package]]
name = "crc32fast"
- version = "1.3.2"
+ version = "1.4.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -809,16 +620,6 @@
- ]
+@@ -827,16 +655,6 @@
+ checksum = "248e3bacc7dc6baa3b21e405ee045c3047101a49145e7e9eca583ab4c2ca5345"
[[package]]
-name = "crypto-common"
@@ -285,8 +241,8 @@
name = "cstr_core"
version = "0.2.6"
source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -835,36 +636,26 @@
- checksum = "b365fabc795046672053e29c954733ec3b05e4be654ab130fe8f1f94d7051f35"
+@@ -866,36 +684,26 @@
+ ]
[[package]]
-name = "deranged"
@@ -332,14 +288,26 @@
name = "dirs"
version = "4.0.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -958,27 +749,6 @@
+@@ -990,39 +798,12 @@
+ ]
+
+ [[package]]
+-name = "endi"
+-version = "1.1.0"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "a3d8a32ae18130a3c84dd492d4215c3d913c3b07c6b63c2eb3eb7ff1101ab7bf"
+-
+-[[package]]
+ name = "endian-type"
+ version = "0.1.2"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "c34f04666d835ff5d62e058c3995147c06f42fe86ff053337632bca83e42702d"
[[package]]
-name = "enumflags2"
--version = "0.7.8"
+-version = "0.7.9"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "5998b4f30320c9d93aed72f63af821bfdac50465b75428fce77b48ec482c3939"
+-checksum = "3278c9d5fb675e0a51dabcf4c0d355f692b064171535ba72361be1528a9d8e8d"
-dependencies = [
- "enumflags2_derive",
- "serde",
@@ -347,20 +315,20 @@
-
-[[package]]
-name = "enumflags2_derive"
--version = "0.7.8"
+-version = "0.7.9"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "f95e2801cd355d4a1a3e3953ce6ee5ae9603a5c833455343a8bfe3f44d418246"
+-checksum = "5c785274071b1b420972453b306eeca06acf4633829db4223b58a2a8c5953bc4"
-dependencies = [
- "proc-macro2",
- "quote",
-- "syn 2.0.47",
+- "syn 2.0.60",
-]
-
-[[package]]
name = "env_logger"
- version = "0.10.1"
+ version = "0.10.2"
source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -1005,23 +775,6 @@
+@@ -1049,12 +830,6 @@
[[package]]
name = "event-listener"
@@ -370,9 +338,17 @@
-
-[[package]]
-name = "event-listener"
--version = "3.1.0"
+ version = "4.0.3"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ checksum = "67b215c49b2b248c855fb73579eb1f4f26c38ffdc12973e20e07b91d78d5646e"
+@@ -1065,37 +840,6 @@
+ ]
+
+ [[package]]
+-name = "event-listener"
+-version = "5.3.0"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "d93877bcde0eb80ca09131a08d23f0a5c18a620b01db137dba666d18cd9b30c2"
+-checksum = "6d9944b8ca13534cdfb2800775f8dd4902ff3fc75a50101466decadfdf322a24"
-dependencies = [
- "concurrent-queue",
- "parking",
@@ -380,68 +356,39 @@
-]
-
-[[package]]
--name = "event-listener"
- version = "4.0.2"
- source = "registry+https://github.com/rust-lang/crates.io-index"
- checksum = "218a870470cce1469024e9fb66b901aa983929d81304a1cdb299f28118e550d5"
-@@ -1032,16 +785,6 @@
- ]
-
- [[package]]
-name = "event-listener-strategy"
-version = "0.4.0"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "958e4d70b6d5e81971bebec42271ec641e7ff4e170a6fa605f2b8a8b65cb97d3"
-dependencies = [
-- "event-listener 4.0.2",
+- "event-listener 4.0.3",
- "pin-project-lite",
-]
-
-[[package]]
- name = "eyra"
- version = "0.16.9"
- source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -1061,15 +804,6 @@
-
- [[package]]
- name = "fastrand"
--version = "1.9.0"
+-name = "event-listener-strategy"
+-version = "0.5.1"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "e51093e27b0797c359783294ca4f0a911c270184cb10f85783b118614a1501be"
+-checksum = "332f51cb23d20b0de8458b86580878211da09bcd4503cb579c225b3d124cabb3"
-dependencies = [
-- "instant",
+- "event-listener 5.3.0",
+- "pin-project-lite",
-]
-
-[[package]]
--name = "fastrand"
- version = "2.0.1"
+ name = "eyra"
+ version = "0.16.10"
source = "registry+https://github.com/rust-lang/crates.io-index"
- checksum = "25cbce373ec4653f1a01a31e8a5e5ec0c622dc27ff9c4e6606eefef5cbbed4a5"
-@@ -1178,34 +912,6 @@
+@@ -1220,19 +964,6 @@
checksum = "a44623e20b9681a318efdd71c299b6b222ed6f231972bfe2f224ebad6311f0c1"
[[package]]
-name = "futures-lite"
--version = "1.13.0"
--source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "49a9d51ce47660b1e808d3c990b4709f2f415d928835a17dfd16991515c46bce"
--dependencies = [
-- "fastrand 1.9.0",
-- "futures-core",
-- "futures-io",
-- "memchr",
-- "parking",
-- "pin-project-lite",
-- "waker-fn",
--]
--
--[[package]]
--name = "futures-lite"
--version = "2.1.0"
+-version = "2.3.0"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "aeee267a1883f7ebef3700f262d2d54de95dfaf38189015a74fdc4e0c7ad8143"
+-checksum = "52527eb5074e35e9339c6b4e8d12600c7128b68fb25dcb9fa9dec18f7c25f3a5"
-dependencies = [
-- "fastrand 2.0.1",
+- "fastrand",
- "futures-core",
- "futures-io",
- "parking",
@@ -452,7 +399,7 @@
name = "futures-macro"
version = "0.3.30"
source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -1247,16 +953,6 @@
+@@ -1274,16 +1005,6 @@
]
[[package]]
@@ -467,76 +414,59 @@
-
-[[package]]
name = "getrandom"
- version = "0.2.11"
+ version = "0.2.14"
source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -1720,7 +1416,7 @@
- source = "registry+https://github.com/rust-lang/crates.io-index"
- checksum = "de6225e2de30b6e9bca2d9f1cc4731640fcef0fb3cabddceee366e7e85d3e94f"
- dependencies = [
-- "fastrand 2.0.1",
-+ "fastrand",
+@@ -1351,7 +1072,7 @@
+ "gix-utils",
+ "itoa",
+ "thiserror",
+- "winnow 0.6.6",
++ "winnow",
]
[[package]]
-@@ -1803,12 +1499,6 @@
- checksum = "d77f7ec81a6d05a3abb01ab6eb7590f6083d08449fe5a1c8b1e620283546ccb7"
+@@ -1395,7 +1116,7 @@
+ "smallvec",
+ "thiserror",
+ "unicode-bom",
+- "winnow 0.6.6",
++ "winnow",
+ ]
[[package]]
--name = "hex"
--version = "0.4.3"
--source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "7f24254aa9a54b5c858eaee2f5bccdb46aaf0e486a595ed5fd8f86ba55232a70"
--
--[[package]]
- name = "home"
- version = "0.5.9"
- source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -1874,7 +1564,7 @@
- "httpdate",
+@@ -1551,7 +1272,7 @@
"itoa",
- "pin-project-lite",
-- "socket2 0.5.5",
-+ "socket2",
- "tokio",
- "tower-service",
- "tracing",
-@@ -2001,33 +1691,13 @@
+ "smallvec",
+ "thiserror",
+- "winnow 0.6.6",
++ "winnow",
]
[[package]]
--name = "instant"
--version = "0.1.12"
--source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "7a5bbe824c507c5da5956355e86a746d82e0e1464f65d862cc5e71da70e94b2c"
--dependencies = [
-- "cfg-if",
--]
--
--[[package]]
--name = "io-lifetimes"
--version = "1.0.11"
+@@ -1637,7 +1358,7 @@
+ "gix-validate",
+ "memmap2",
+ "thiserror",
+- "winnow 0.6.6",
++ "winnow",
+ ]
+
+ [[package]]
+@@ -1841,12 +1562,6 @@
+ checksum = "d231dfb89cfffdbc30e7fc41579ed6066ad03abda9e567ccafae602b97ec5024"
+
+ [[package]]
+-name = "hex"
+-version = "0.4.3"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "eae7b9aee968036d54dce06cebaefd919e4472e753296daccd6d344e3e2df0c2"
--dependencies = [
-- "hermit-abi",
-- "libc",
-- "windows-sys 0.48.0",
--]
+-checksum = "7f24254aa9a54b5c858eaee2f5bccdb46aaf0e486a595ed5fd8f86ba55232a70"
-
-[[package]]
- name = "is-terminal"
- version = "0.4.10"
+ name = "hifijson"
+ version = "0.2.1"
source = "registry+https://github.com/rust-lang/crates.io-index"
- checksum = "0bad00257d07be169d870ab665980b06cdb366d792ad690bf2e76876dc503455"
- dependencies = [
- "hermit-abi",
-- "rustix 0.38.28",
-+ "rustix",
- "windows-sys 0.52.0",
- ]
-
-@@ -2103,6 +1773,15 @@
- checksum = "302d7ab3130588088d277783b1e2d2e10c9e9e4a16dd9050e6ec93fb3e7048f4"
+@@ -2189,6 +1904,15 @@
+ checksum = "9c198f91728a82281a64e1f4f9eeb25d82cb32a5de251c6bd1b5154d63a8e7bd"
[[package]]
+name = "libdbus-sys"
@@ -551,46 +481,17 @@
name = "libm"
version = "0.2.8"
source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -2131,12 +1810,6 @@
-
- [[package]]
- name = "linux-raw-sys"
--version = "0.3.8"
--source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "ef53942eb7bf7ff43a617b3e2c1c4a5ecf5944a7c1bc12d7ee39bbb15e5c1519"
--
--[[package]]
--name = "linux-raw-sys"
- version = "0.4.12"
- source = "registry+https://github.com/rust-lang/crates.io-index"
- checksum = "c4cd1a83af159aa67994778be9070f0ae1bd732942279cabb14f86f986a21456"
-@@ -2229,15 +1902,6 @@
-
- [[package]]
- name = "memoffset"
--version = "0.7.1"
--source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "5de893c32cde5f383baa4c04c5d6dbdd735cfd4a794b0debdb2bb1b421da5ff4"
--dependencies = [
-- "autocfg",
--]
--
--[[package]]
--name = "memoffset"
- version = "0.9.0"
- source = "registry+https://github.com/rust-lang/crates.io-index"
- checksum = "5a634b1c61a95585bd15607c6ab0c4e5b226e695ff2800ba0cdccddf208c406c"
-@@ -2337,7 +2001,6 @@
- "bitflags 1.3.2",
+@@ -2411,7 +2135,6 @@
"cfg-if",
+ "cfg_aliases",
"libc",
-- "memoffset 0.7.1",
+- "memoffset",
]
[[package]]
-@@ -2399,11 +2062,10 @@
+@@ -2462,11 +2185,10 @@
source = "registry+https://github.com/rust-lang/crates.io-index"
- checksum = "827c5edfa80235ded4ab3fe8e9dc619b4f866ef16fe9b1c6b8a7f8692c0f2226"
+ checksum = "5312f837191c317644f313f7b2b39f9cb1496570c74f7c17152dd3961219551f"
dependencies = [
+ "dbus",
"log",
@@ -601,7 +502,7 @@
]
[[package]]
-@@ -2505,16 +2167,6 @@
+@@ -2574,16 +2296,6 @@
checksum = "04744f49eae99ab78e0d5c0b603ab218f515ea8cfe5a456d7629ad883a3b6e7d"
[[package]]
@@ -616,65 +517,36 @@
-
-[[package]]
name = "origin"
- version = "0.17.0"
+ version = "0.18.2"
source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -2522,10 +2174,10 @@
- dependencies = [
- "bitflags 2.4.1",
- "env_logger",
-- "linux-raw-sys 0.4.12",
-+ "linux-raw-sys",
- "log",
-- "memoffset 0.9.0",
-- "rustix 0.38.28",
-+ "memoffset",
-+ "rustix",
- "rustix-futex-sync",
- "smallvec",
- "unwinding",
-@@ -2669,47 +2321,12 @@
+@@ -2738,32 +2450,12 @@
checksum = "8b870d8c151b6f2fb93e84a13146138f05d02ed11c7e7c54f8826aaaf7c9f184"
[[package]]
-name = "piper"
-version = "0.2.1"
+name = "pkg-config"
-+version = "0.3.28"
++version = "0.3.30"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "668d31b1c4eba19242f2088b2bf3316b82ca31082a8335764db4e083db7485d4"
-dependencies = [
- "atomic-waker",
-- "fastrand 2.0.1",
+- "fastrand",
- "futures-io",
-]
-+checksum = "69d3587f8a9e599cc7ec2c00e331f71c4e69a5f9a4b8a6efd5b07466b9736f9a"
++checksum = "d231b230927b5e4ad203db57bbcbee2802f6bce620b1e4a9024a07d94e2907ec"
[[package]]
-name = "polling"
--version = "2.8.0"
+-version = "3.6.0"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "4b2d323e8ca7996b3e23126511a523f7e62924d93ecd5ae73b333815b0eb3dce"
--dependencies = [
-- "autocfg",
-- "bitflags 1.3.2",
-- "cfg-if",
-- "concurrent-queue",
-- "libc",
-- "log",
-- "pin-project-lite",
-- "windows-sys 0.48.0",
--]
--
--[[package]]
--name = "polling"
--version = "3.3.1"
--source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "cf63fa624ab313c11656b4cda960bfc46c410187ad493c41f6ba2d8c1e991c9e"
+-checksum = "e0c976a60b2d7e99d6f229e414670a9b85d13ac305cc6d1e9c134de58c5aaaf6"
-dependencies = [
- "cfg-if",
- "concurrent-queue",
+- "hermit-abi",
- "pin-project-lite",
-- "rustix 0.38.28",
+- "rustix",
- "tracing",
- "windows-sys 0.52.0",
-]
@@ -683,99 +555,41 @@
name = "posix-regex"
version = "0.1.1"
source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -2740,16 +2357,6 @@
+@@ -2794,15 +2486,6 @@
]
[[package]]
-name = "proc-macro-crate"
--version = "1.3.1"
+-version = "3.1.0"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "7f4c021e1093a56626774e81216a4ce732a735e5bad4868a03f3ed65ca0c3919"
+-checksum = "6d37c51ca738a55da99dc0c4a34860fd675453b8b36209178c2249bb13651284"
-dependencies = [
-- "once_cell",
-- "toml_edit 0.19.15",
+- "toml_edit 0.21.1",
-]
-
-[[package]]
name = "proc-macro2"
- version = "1.0.75"
- source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -2972,20 +2579,6 @@
-
- [[package]]
- name = "rustix"
--version = "0.37.27"
--source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "fea8ca367a3a01fe35e6943c400addf443c0f57670e6ec51196f71a4b8762dd2"
--dependencies = [
-- "bitflags 1.3.2",
-- "errno",
-- "io-lifetimes",
-- "libc",
-- "linux-raw-sys 0.3.8",
-- "windows-sys 0.48.0",
--]
--
--[[package]]
--name = "rustix"
- version = "0.38.28"
+ version = "1.0.81"
source = "registry+https://github.com/rust-lang/crates.io-index"
- checksum = "72e572a5e8ca657d7366229cdde4bd14c4eb5499a9573d4d366fe1b599daa316"
-@@ -2994,7 +2587,7 @@
- "errno",
- "itoa",
- "libc",
-- "linux-raw-sys 0.4.12",
-+ "linux-raw-sys",
- "once_cell",
- "windows-sys 0.52.0",
- ]
-@@ -3005,7 +2598,7 @@
- source = "registry+https://github.com/rust-lang/crates.io-index"
- checksum = "a0fab868d3bd1ac5de1f1507e58fab624339e5bb201049e3329767974ba219ec"
- dependencies = [
-- "rustix 0.38.28",
-+ "rustix",
- "rustix-futex-sync",
- ]
-
-@@ -3016,7 +2609,7 @@
- checksum = "fbf5fb8d04cb2409733689b671078896d4a79ebb34cee0b9067fa4e82e072484"
- dependencies = [
- "lock_api",
-- "rustix 0.38.28",
-+ "rustix",
- ]
-
- [[package]]
-@@ -3027,7 +2620,7 @@
- dependencies = [
- "errno",
- "libc",
-- "rustix 0.38.28",
-+ "rustix",
- ]
-
- [[package]]
-@@ -3095,17 +2688,6 @@
+@@ -3170,17 +2853,6 @@
]
[[package]]
-name = "serde_repr"
--version = "0.1.18"
+-version = "0.1.19"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "0b2e6b945e9d3df726b65d6ee24060aff8e3533d431f677a9695db04eff9dfdb"
+-checksum = "6c64451ba24fc7a6a2d60fc75dd9c83c90903b19028d4eff35e88fc1e86564e9"
-dependencies = [
- "proc-macro2",
- "quote",
-- "syn 2.0.47",
+- "syn 2.0.60",
-]
-
-[[package]]
name = "serde_spanned"
version = "0.6.5"
source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -3115,17 +2697,6 @@
+@@ -3190,17 +2862,6 @@
]
[[package]]
@@ -793,24 +607,7 @@
name = "sha1_smol"
version = "1.0.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -3216,16 +2787,6 @@
-
- [[package]]
- name = "socket2"
--version = "0.4.10"
--source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "9f7916fc008ca5542385b89a3d3ce689953c143e9304a9bf8beec1de48994c0d"
--dependencies = [
-- "libc",
-- "winapi",
--]
--
--[[package]]
--name = "socket2"
- version = "0.5.5"
- source = "registry+https://github.com/rust-lang/crates.io-index"
- checksum = "7b5fac59a5cb5dd637972e5fca70daf0523c9067fcdc4842f053dae04a18f8e9"
-@@ -3235,12 +2796,6 @@
+@@ -3300,12 +2961,6 @@
]
[[package]]
@@ -821,66 +618,45 @@
-
-[[package]]
name = "strsim"
- version = "0.10.0"
+ version = "0.11.1"
source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -3319,9 +2874,9 @@
- checksum = "01ce4141aa927a6d1bd34a041795abd0db1cccba5d5f24b009f694bdf3a1f3fa"
- dependencies = [
- "cfg-if",
-- "fastrand 2.0.1",
-+ "fastrand",
- "redox_syscall",
-- "rustix 0.38.28",
-+ "rustix",
- "windows-sys 0.52.0",
- ]
-
-@@ -3350,7 +2905,7 @@
- source = "registry+https://github.com/rust-lang/crates.io-index"
- checksum = "21bebf2b7c9e0a515f6e0f8c51dc0f8e4696391e6f1ff30379559f8365fb0df7"
- dependencies = [
-- "rustix 0.38.28",
-+ "rustix",
- "windows-sys 0.48.0",
- ]
-
-@@ -3467,7 +3022,7 @@
- "num_cpus",
- "pin-project-lite",
- "signal-hook-registry",
-- "socket2 0.5.5",
-+ "socket2",
- "tokio-macros",
- "tracing",
- "windows-sys 0.48.0",
-@@ -3528,7 +3083,7 @@
+@@ -3578,7 +3233,7 @@
"serde",
"serde_spanned",
"toml_datetime",
-- "toml_edit 0.21.0",
+- "toml_edit 0.22.12",
+ "toml_edit",
]
[[package]]
-@@ -3542,17 +3097,6 @@
+@@ -3592,17 +3247,6 @@
[[package]]
name = "toml_edit"
--version = "0.19.15"
+-version = "0.21.1"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "1b5bb770da30e5cbfde35a2d7b9b8a2c4b8ef89548a7a6aeab5c9a576e3e7421"
+-checksum = "6a8534fd7f78b5405e860340ad6575217ce99f38d4d5c8f2442cb5ecb50090e1"
-dependencies = [
-- "indexmap 2.1.0",
+- "indexmap 2.2.6",
- "toml_datetime",
-- "winnow",
+- "winnow 0.5.40",
-]
-
-[[package]]
-name = "toml_edit"
- version = "0.21.0"
+ version = "0.22.12"
source = "registry+https://github.com/rust-lang/crates.io-index"
- checksum = "d34d383cd00a163b4a5b85053df514d45bc330f6de7737edfe0a93311d1eaa03"
-@@ -3761,29 +3305,12 @@
+ checksum = "d3328d4f68a705b2a4498da1d580585d39a6510f98318a2cec3018a7ec61ddef"
+@@ -3611,7 +3255,7 @@
+ "serde",
+ "serde_spanned",
+ "toml_datetime",
+- "winnow 0.6.6",
++ "winnow",
+ ]
+
+ [[package]]
+@@ -3778,29 +3422,12 @@
checksum = "e421abadd41a4225275504ea4d6566923418b7f05506fbc9c0fe86ba7396114b"
[[package]]
@@ -901,88 +677,68 @@
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "89daebc3e6fd160ac4aa9fc8b3bf71e1f74fbf92367ae71fb83a037e8bf164b9"
-dependencies = [
-- "memoffset 0.9.0",
+- "memoffset",
- "tempfile",
- "winapi",
-]
-
-[[package]]
- name = "unicase"
- version = "2.7.0"
+ name = "unicode-bidi"
+ version = "0.3.15"
source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -3901,12 +3428,6 @@
- ]
+@@ -4392,15 +4019,6 @@
[[package]]
--name = "waker-fn"
--version = "1.1.1"
+ name = "winnow"
+-version = "0.5.40"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "f3c4517f54858c779bbcbf228f4fca63d121bf85fbecb2dc578cdf4a39395690"
+-checksum = "f593a95398737aeed53e489c785df13f3618e41dbcd6718c6addbf1395aa6876"
+-dependencies = [
+- "memchr",
+-]
-
-[[package]]
- name = "walkdir"
- version = "2.4.0"
+-name = "winnow"
+ version = "0.6.6"
source = "registry+https://github.com/rust-lang/crates.io-index"
-@@ -4153,7 +3674,7 @@
- "either",
- "home",
- "once_cell",
-- "rustix 0.38.28",
-+ "rustix",
- ]
+ checksum = "f0c976aaaa0e1f90dbb21e9587cdaf1d9679a1cde8875c0d6bd83ab96a208352"
+@@ -4425,80 +4043,6 @@
+ checksum = "d135d17ab770252ad95e9a872d365cf3090e3be864a34ab46f48555993efc904"
[[package]]
-@@ -4165,7 +3686,7 @@
- "either",
- "home",
- "once_cell",
-- "rustix 0.38.28",
-+ "rustix",
- "windows-sys 0.48.0",
- ]
-
-@@ -4387,118 +3908,4 @@
- dependencies = [
- "cfg-if",
- "windows-sys 0.48.0",
--]
--
--[[package]]
-name = "xdg-home"
--version = "1.0.0"
+-version = "1.1.0"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "2769203cd13a0c6015d515be729c526d041e9cf2c0cc478d57faee85f40c6dcd"
+-checksum = "21e5a325c3cb8398ad6cf859c1135b25dd29e186679cf2da7581d9679f63b38e"
-dependencies = [
-- "nix 0.26.4",
+- "libc",
- "winapi",
-]
-
-[[package]]
-name = "zbus"
--version = "3.14.1"
+-version = "4.1.2"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "31de390a2d872e4cd04edd71b425e29853f786dc99317ed72d73d6fcf5ebb948"
+-checksum = "c9ff46f2a25abd690ed072054733e0bc3157e3d4c45f41bd183dce09c2ff8ab9"
-dependencies = [
- "async-broadcast",
- "async-executor",
- "async-fs",
-- "async-io 1.13.0",
-- "async-lock 2.8.0",
+- "async-io",
+- "async-lock 3.3.0",
- "async-process",
- "async-recursion",
- "async-task",
- "async-trait",
- "blocking",
-- "byteorder",
- "derivative",
- "enumflags2",
-- "event-listener 2.5.3",
+- "event-listener 5.3.0",
- "futures-core",
- "futures-sink",
- "futures-util",
- "hex",
-- "nix 0.26.4",
-- "once_cell",
+- "nix 0.28.0",
- "ordered-stream",
- "rand",
- "serde",
@@ -991,7 +747,7 @@
- "static_assertions",
- "tracing",
- "uds_windows",
-- "winapi",
+- "windows-sys 0.52.0",
- "xdg-home",
- "zbus_macros",
- "zbus_names",
@@ -1000,9 +756,9 @@
-
-[[package]]
-name = "zbus_macros"
--version = "3.14.1"
+-version = "4.1.2"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "41d1794a946878c0e807f55a397187c11fc7a038ba5d868e7db4f3bd7760bc9d"
+-checksum = "4e0e3852c93dcdb49c9462afe67a2a468f7bd464150d866e861eaf06208633e0"
-dependencies = [
- "proc-macro-crate",
- "proc-macro2",
@@ -1014,9 +770,9 @@
-
-[[package]]
-name = "zbus_names"
--version = "2.6.0"
+-version = "3.0.0"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "fb80bb776dbda6e23d705cf0123c3b95df99c4ebeaec6c2599d4a5419902b4a9"
+-checksum = "4b9b1fef7d021261cc16cba64c351d291b715febe0fa10dc3a443ac5a5022e6c"
-dependencies = [
- "serde",
- "static_assertions",
@@ -1024,14 +780,23 @@
-]
-
-[[package]]
+ name = "zerocopy"
+ version = "0.7.32"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+@@ -4516,41 +4060,4 @@
+ "proc-macro2",
+ "quote",
+ "syn 2.0.60",
+-]
+-
+-[[package]]
-name = "zvariant"
--version = "3.15.0"
+-version = "4.0.2"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "44b291bee0d960c53170780af148dca5fa260a63cdd24f1962fa82e03e53338c"
+-checksum = "2c1b3ca6db667bfada0f1ebfc94b2b1759ba25472ee5373d4551bb892616389a"
-dependencies = [
-- "byteorder",
+- "endi",
- "enumflags2",
-- "libc",
- "serde",
- "static_assertions",
- "zvariant_derive",
@@ -1039,9 +804,9 @@
-
-[[package]]
-name = "zvariant_derive"
--version = "3.15.0"
+-version = "4.0.2"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "934d7a7dfc310d6ee06c87ffe88ef4eca7d3e37bb251dece2ef93da8f17d8ecd"
+-checksum = "b7a4b236063316163b69039f77ce3117accb41a09567fd24c168e43491e521bc"
-dependencies = [
- "proc-macro-crate",
- "proc-macro2",
@@ -1052,9 +817,9 @@
-
-[[package]]
-name = "zvariant_utils"
--version = "1.0.1"
+-version = "1.1.0"
-source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "7234f0d811589db492d16893e3f21e8e2fd282e6d01b0cddee310322062cc200"
+-checksum = "00bedb16a193cc12451873fee2a1bc6550225acece0e36f333e68326c73c8172"
-dependencies = [
- "proc-macro2",
- "quote",
@@ -1062,12 +827,12 @@
]
--- a/crates/cli/Cargo.toml
+++ b/crates/cli/Cargo.toml
-@@ -30,7 +30,7 @@
- futures = "0.3.29"
- humantime = "2.1.0"
- is-terminal = "0.4.4"
+@@ -38,7 +38,7 @@
+ jaq-parse = "1.0.2"
+ jaq-std = "1.2.1"
+ jaq-syn = "1.1.0"
-notify-rust = "4.9.0"
+notify-rust = { version = "4.9.0", default-features = false, features = ["d"] }
+ once_cell = "1.17.1"
serde_json = "1.0.107"
tempfile = "3.8.1"
- termcolor = "1.4.0"