aboutsummaryrefslogtreecommitdiffstats
path: root/community/index
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-08-03 21:09:51 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-08-26 08:48:21 +0000
commit687b10901d45faa7b3792ee36283768f9a18537f (patch)
tree5ef843cf3bd6cedbe9bc12c711169c7dc4d28617 /community/index
parent1d6d51bd44298aa2c089baabdeb2feebb4df9a95 (diff)
community/index: move from testing
Diffstat (limited to 'community/index')
-rw-r--r--community/index/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/index/APKBUILD b/community/index/APKBUILD
new file mode 100644
index 00000000000..09e04628c78
--- /dev/null
+++ b/community/index/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=index
+pkgver=1.1.1
+pkgrel=0
+pkgdesc="Index file manager based on MauiKit"
+arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+url="https://invent.kde.org/kde/index-fm"
+license="GPL-2.0-or-later"
+depends="mauikit"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev mauikit-dev kservice-dev knotifications-dev ki18n-dev kio-dev"
+source="https://invent.kde.org/kde/index-fm/-/archive/v$pkgver/index-fm-v$pkgver.tar.gz"
+options="!check" # No tests available
+builddir="$srcdir/$pkgname-fm-v$pkgver"
+
+build() {
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --build build --target install
+}
+sha512sums="86ee76796d377444dd7ba3d57993e979ce9e094f70aef6307b02674af3d9427e9fb8f575418322079b60fff17f8a77ffee9a0c61aa0b2fcf104e4eb8daef2973 index-fm-v1.1.1.tar.gz"