aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/gnome-authenticator/0001-Remove-init_template-calls.patch118
-rw-r--r--community/gnome-authenticator/APKBUILD23
-rw-r--r--community/gnome-authenticator/dont-require-py3-gettext-support.patch38
3 files changed, 10 insertions, 169 deletions
diff --git a/community/gnome-authenticator/0001-Remove-init_template-calls.patch b/community/gnome-authenticator/0001-Remove-init_template-calls.patch
deleted file mode 100644
index c4d55295c20..00000000000
--- a/community/gnome-authenticator/0001-Remove-init_template-calls.patch
+++ /dev/null
@@ -1,118 +0,0 @@
-From 4604cc68b2e7d8a16e3787b4148b031d69bf865b Mon Sep 17 00:00:00 2001
-From: Adam Plumb <adamplumb@gmail.com>
-Date: Fri, 6 Aug 2021 18:21:33 -0400
-Subject: [PATCH] Remove init_template calls
-
----
- src/Authenticator/widgets/accounts/add.py | 2 --
- src/Authenticator/widgets/accounts/edit.py | 1 -
- src/Authenticator/widgets/accounts/list.py | 1 -
- src/Authenticator/widgets/accounts/row.py | 1 -
- src/Authenticator/widgets/provider_image.py | 1 -
- src/Authenticator/widgets/settings.py | 2 --
- src/Authenticator/widgets/window.py | 1 -
- 7 files changed, 9 deletions(-)
-
-diff --git a/src/Authenticator/widgets/accounts/add.py b/src/Authenticator/widgets/accounts/add.py
-index 98e4d24..97f69e9 100644
---- a/src/Authenticator/widgets/accounts/add.py
-+++ b/src/Authenticator/widgets/accounts/add.py
-@@ -38,7 +38,6 @@ class AddAccountWindow(Gtk.Window):
-
- def __init__(self):
- super(AddAccountWindow, self).__init__()
-- self.init_template('AddAccountWindow')
- self.add_events(Gdk.EventMask.ENTER_NOTIFY_MASK)
- self.__init_widgets()
-
-@@ -95,7 +94,6 @@ class AccountConfig(Gtk.Overlay):
-
- def __init__(self, **kwargs):
- super(AccountConfig, self).__init__()
-- self.init_template('AccountConfig')
-
- self.props.is_edit = kwargs.get("edit", False)
- self._account = kwargs.get("account", None)
-diff --git a/src/Authenticator/widgets/accounts/edit.py b/src/Authenticator/widgets/accounts/edit.py
-index a047178..7b7d8b2 100644
---- a/src/Authenticator/widgets/accounts/edit.py
-+++ b/src/Authenticator/widgets/accounts/edit.py
-@@ -36,7 +36,6 @@ class EditAccountWindow(Gtk.Window):
-
- def __init__(self, account):
- super(EditAccountWindow, self).__init__()
-- self.init_template('EditAccountWindow')
-
- self._account = account
- self.__init_widgets()
-diff --git a/src/Authenticator/widgets/accounts/list.py b/src/Authenticator/widgets/accounts/list.py
-index f7cece8..ee81e24 100644
---- a/src/Authenticator/widgets/accounts/list.py
-+++ b/src/Authenticator/widgets/accounts/list.py
-@@ -40,7 +40,6 @@ class AccountsWidget(Gtk.Box):
-
- def __init__(self):
- super(AccountsWidget, self).__init__()
-- self.init_template('AccountsWidget')
-
- self._providers = []
- self._to_delete = []
-diff --git a/src/Authenticator/widgets/accounts/row.py b/src/Authenticator/widgets/accounts/row.py
-index 2f660b3..18dd24f 100644
---- a/src/Authenticator/widgets/accounts/row.py
-+++ b/src/Authenticator/widgets/accounts/row.py
-@@ -61,7 +61,6 @@ class AccountRow(Gtk.ListBoxRow):
- :param account: Account
- """
- super(AccountRow, self).__init__()
-- self.init_template('AccountRow')
- self._account = account
-
- self._account.connect("otp_updated", self._on_pin_updated)
-diff --git a/src/Authenticator/widgets/provider_image.py b/src/Authenticator/widgets/provider_image.py
-index 36237a9..32710c8 100644
---- a/src/Authenticator/widgets/provider_image.py
-+++ b/src/Authenticator/widgets/provider_image.py
-@@ -78,7 +78,6 @@ class ProviderImage(Gtk.Stack):
-
- def __init__(self, provider=None, image_size=48):
- super(ProviderImage, self).__init__()
-- self.init_template('ProviderImage')
- self.provider = provider if provider else Provider()
-
- self.image_size = image_size
-diff --git a/src/Authenticator/widgets/settings.py b/src/Authenticator/widgets/settings.py
-index 4920390..49a98a9 100644
---- a/src/Authenticator/widgets/settings.py
-+++ b/src/Authenticator/widgets/settings.py
-@@ -37,7 +37,6 @@ class SettingsWindow(Handy.PreferencesWindow):
-
- def __init__(self):
- super(SettingsWindow, self).__init__()
-- self.init_template('SettingsWindow')
-
- self.__init_widgets()
- self.__bind_signals()
-@@ -150,7 +149,6 @@ class PasswordWidget(Gtk.Box):
- def __init__(self):
- super(PasswordWidget, self).__init__()
- self.parent = None
-- self.init_template('PasswordWidget')
-
- def reset_widgets(self):
- """Reset widgets state."""
-diff --git a/src/Authenticator/widgets/window.py b/src/Authenticator/widgets/window.py
-index ec6f6f7..b3336a3 100644
---- a/src/Authenticator/widgets/window.py
-+++ b/src/Authenticator/widgets/window.py
-@@ -52,7 +52,6 @@ class Window(Gtk.ApplicationWindow):
-
- def __init__(self):
- super(Window, self).__init__()
-- self.init_template('Window')
-
- self.connect("notify::view", self.__state_changed)
-
---
-2.32.0
-
diff --git a/community/gnome-authenticator/APKBUILD b/community/gnome-authenticator/APKBUILD
index 76c5c635820..e89a70e2281 100644
--- a/community/gnome-authenticator/APKBUILD
+++ b/community/gnome-authenticator/APKBUILD
@@ -1,21 +1,18 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gnome-authenticator
-pkgver=3.32.2
-pkgrel=11
+pkgver=4.0.3
+pkgrel=0
pkgdesc="Two-Factor Authentication application"
url="https://gitlab.gnome.org/World/Authenticator"
-# s390x and mips64 blocked by libhandy
-arch="noarch !s390x !mips64"
+# s390x, mips64, riscv64 blocked by libadwaita
+# x86, ppc64le building dependency ring v0.16.20 fails
+arch="all !s390x !mips64 !riscv64 !x86 !ppc64le"
license="GPL-3.0-only"
-depends="python3 py3-otp py3-beautifulsoup4 py3-pillow py3-pyfavicon py3-pyzbar
- py3-yoyo-migrations libhandy py3-setuptools"
-makedepends="meson gtk+3.0-dev libsecret-dev zbar-dev gobject-introspection-dev"
+makedepends="meson cargo gstreamer-dev gst-plugins-bad-dev gst-plugins-base-dev gtk4.0-dev libadwaita-dev zbar-dev"
checkdepends="appstream-glib desktop-file-utils"
subpackages="$pkgname-lang"
-source="https://gitlab.gnome.org/World/Authenticator/-/archive/$pkgver/Authenticator-$pkgver.tar.gz
- dont-require-py3-gettext-support.patch
- 0001-Remove-init_template-calls.patch"
+source="https://gitlab.gnome.org/World/Authenticator/-/archive/$pkgver/Authenticator-$pkgver.tar.gz"
builddir="$srcdir/Authenticator-$pkgver"
build() {
@@ -31,6 +28,6 @@ package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="3bd78354f4d18052d03650b455f07fb7fa9bb5cba0b6c92dcbfb5158dcf500f0b7f84e0be8942e0fbb74b1cefcd9019941c758538e05144c469bbe47b4355ce0 Authenticator-3.32.2.tar.gz
-04ce91e3c12503fb21728c39cf20ab1cd5c81f0ad7b5f6ecc875921c387df5fcc3edb4675e0015f1ba7eda71cf53246b9c14b819a11d5d151846112966aa10c0 dont-require-py3-gettext-support.patch
-bac065e33d70db2b27dd1302fc97d916173b07b32a84d5f3645c320c6a0a5c91ee8a031dd3114c94bda117196ef177942e119c87c5d9a9732efad2182b416223 0001-Remove-init_template-calls.patch"
+sha512sums="
+cfd5d1a51de0f5b943a70949b354c1af01db05f3523cfcbb700352789c1dd85e13dd57c390b159b640247bf96e0107d01653464715e865f45724127f8a2458ce Authenticator-4.0.3.tar.gz
+"
diff --git a/community/gnome-authenticator/dont-require-py3-gettext-support.patch b/community/gnome-authenticator/dont-require-py3-gettext-support.patch
deleted file mode 100644
index 0612747d1d2..00000000000
--- a/community/gnome-authenticator/dont-require-py3-gettext-support.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Upstream: Pending, https://gitlab.gnome.org/World/Authenticator/-/merge_requests/160
-From 4073b3f3d97f0c4d74a7017da181fb4e41bdef8e Mon Sep 17 00:00:00 2001
-From: Rasmus Thomsen <oss@cogitri.dev>
-Date: Wed, 8 Jul 2020 18:08:16 +0200
-Subject: [PATCH] Gracefully handle locale.{bind,}textdomain not being
- available
-
-When python is built without gettext support these functions aren't
-available and as such GTG fails to start without this change.
----
- src/authenticator.py.in | 11 +++++++++--
- 1 file changed, 9 insertions(+), 2 deletions(-)
-
-diff --git a/src/authenticator.py.in b/src/authenticator.py.in
-index 1e75e10..2cc371f 100755
---- a/src/authenticator.py.in
-+++ b/src/authenticator.py.in
-@@ -35,8 +35,15 @@ from gi.repository import Gio, Handy
- sys.path.insert(1, '@PYTHON_DIR@')
-
- def prepare_locale():
-- locale.bindtextdomain('@GETTEXT_PACKAGE@', '@LOCALE_DIR@')
-- locale.textdomain('@GETTEXT_PACKAGE@')
-+ try:
-+ locale.bindtextdomain('@GETTEXT_PACKAGE@', '@LOCALE_DIR@')
-+ locale.textdomain('@GETTEXT_PACKAGE@')
-+ except AttributeError as e:
-+ # Python built without gettext support doesn't have bindtextdomain()
-+ # and textdomain()
-+ print("Couldn't bind the gettext translation domain. Some translations"
-+ " won't work.\n{}".format(e))
-+
- gettext.bindtextdomain('@GETTEXT_PACKAGE@', '@LOCALE_DIR@')
- gettext.textdomain('@GETTEXT_PACKAGE@')
-
---
-GitLab
-